3

Apologies for the long story, feel free to skip. :)

So I goofed up pretty amusingly the other day.

I bought a $10 LG Optimus Exceed, rooted it with Towelroot, then downloaded the jumobile System App Uninstaller to remove some of the Verizon bloatware since I have no intention of activating it. I was careful not to remove any of the packages it flagged as important. Now, this phone only has 4GB of disk space total, and that doesn't last long considering how monstrous the Google apps are these days. So I saw the default LG keyboard taking up far more room than I thought should be necessary. I removed it and installed a different one. Mistake #1.

Some time later I tried to open Settings. It crashed.

A smart man may have gone into that jumobile app and restored some of the apps to try and get it back. Maybe that would have worked. I wouldn't know because I did the worst thing.

I did a Factory Reset. Mistake #2.

The Settings app still crashes. In case you didn't know, apps that are installed as system apps don't get restored if you remove them as root. So now I don't have a keyboard, and I can't enable keyboards. I can't switch into USB debug mode. I can't enable third-party apps, which means I can't root. Through a fancy combination of voice input, the built-in clipboard manager, copying and pasting, and some luck that Google Play opens a little thing that allows me to do it without entering the Settings app, I have my Google account and my wireless set up. But I can't get any further in getting my little $10 toy back in shape.

So, my Settings app crashes and I don't have a keyboard. How do I enable one?

I'm a long-time Linux user, but the Android terminal is pretty opaque to me. Still, I feel like it should be possible to enable a keyboard from the command line. When I install a keyboard it tries to launch that activity directly, but that crashes.

So can I use the Terminal emulator to enable an installed keyboard?

If not, can I use the terminal to allow third party sources, root, and then do something that way?

Is there some way I can fix or replace my Settings app? I can't clear the cache through the normal way (obviously), and third party apps to clear caches didn't work.

Is there any hope, or is this now just a glorified video player?

  • 1
    Related: how to change input method with ime command – Firelord Oct 21 '15 at 2:44
  • Man, you seem to do quote a lot on your newly bought phone. Had you just disabled those apps soon after phone start the first time, those would have never taken any space, like in my phone, Facebook and it's Manager take 2KB space. Otherwise, if I were you, I would have simply waited, got a bit more money, and bought a better phone. – Wrichik Basu Aug 23 '17 at 15:42
  • Idk why you can't open settings, just flash stock firmware (root and custom recovrry will be gone) and do it again but be careful this time – Једноруки Крстивоје Aug 23 '17 at 15:56
2

Yes you can enable an installed keyboard from the Terminal emulator (ime enable/set xxx), but you still would have to type something and you said you don't have a keyboard... Get a hand on an OTG adapter, this way you can directly plug a physical USB keyboard and type what you need. You could also install a keyboard like SwiftKey (from Google Play desktop). You should be able to open its app by clicking in the notification tray then it will help open the part of the setting screen to enable this keyboard (if this part doesn't crash).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.