53

I have a Nexus 5 phone and ever since I allowed a system update, it won't let me post pictures to Instagram. It keeps talking about turning off a "screen overlay", but then when I try to follow the steps to get to that setting, it just sends me in a loop and doesn't actually let me change anything.

(Click image to enlarge)

IMG: And it takes me here, but I can't actually slide the bar into the 'on' position. So I go to the Instagram settings and then permissions and it won't let me change those either IMG: This just shows up again

  • 11
    It seems that you are using a Screen Filtering app(the brownish overlay on the screen). Turn off and it won't bug you. – Lucky Oct 23 '15 at 6:36
  • 3
    So CF.Lumen or Twlight need to be disabled here. – Antony Dec 29 '15 at 4:05
  • 1
    My guess is that this is a security measure to prevent apps from "pressing buttons" on your behalf. It works for me when I temporarily deactivate Lux (brightness control app). By the looks of your screenshots, you're probably using something similar to reduce blue light. Try turning it off until you've edited the permissions – Tymric Mar 29 '16 at 8:47
  • 2
    Note that the overlay app is only preventing access to the app permissions settings menu, not the app itself. Once you've disabled the overlay and set the appropriate permissions, you can turn the overlay (e.g. Twilight) back on without disabling the other app. – Kyle Strand Jun 11 '16 at 7:14
  • 1
    @Lucky you have the correct answer, why are the other answers even here. – Rohit Gupta Sep 12 '16 at 23:42
15

Simple Resolution / Answer

I had this same problem with my Nexus 5X, using Android M. I also went ahead & turned all the permissions off, except for Twilight, the suspected culprit. I still had the problem. So I went ahead and also turned over the overlay for Twilight, and I did not have the problem.

So, Twilight is the "problem", in my case and in the case shown above. (I put problem in quotes because it seems to me like Twilight should not be to blame in this case. Instead, multiple overlays should be possible.)


Where is This Setting??

For those who had this problem, or want to understand what we're talking about, here are the steps to get to this "hidden" setting, within Android M:

  1. Open settings (the nut / gear).
  2. Scroll down to Apps.
  3. From within the Apps portion of settings, again choose the settings gear / nut.
  4. Choose Draw over other apps.
  5. (Optional) Click on the additional menu (the 3 dots), then choose Show system to get at all of the apps that are asking to draw over others, including system apps like Phone Services.

What's Really Going On?

Last little tidbit: I am not 100% certain about this, but from what I know of Android, it seems things work as follows in Mashmallow:

  • Permissions are not asked / required upon app installation, but rather upon when the app needs that permission. Similarly, some permissions can be granted or rejected... the app will work to the best of its capability, if the permission is rejected.

  • Since this is the case, any time an app asks for permission to a particular thing, such as drawing over other apps, the user's yes or no response is recorded.

    • As the user, you can change your response later, which is the essence of what that pop-up window is asking: the window is saying, "I cannot do what I need to do, unless you change your answer to that earlier problem". (However, without highlighting which app is the actual problem, the error seems fairly useless, IMHO.)
10

This is a kludge and probably only a partial solution. I followed the messages to the permission screen, selected the option "apps with this permission" then proceeded to turn off the overlay permission on all apps that had it set on. I was then able to enable the permission that the app I was running required. Because I turned off the permission on all apps, I do not know which app was causing the problem. Will see if any apps stop functioning as I expect.

  • 13
    From my research, it appears the most likely culprits are ones that affect screen brightness, like Lux or Twilight. – howcheng Dec 25 '15 at 23:24
  • 1
    @howcheng Thanks for your comment a lot! Finally I know how to make things work! Please consider making it a separate answer to both: receive appreciation + increase visibility of resolution with (hopefully) benefit to other readers! – Grzegorz Wierzowiecki Jan 14 '16 at 15:49
  • 1
    I also suspect Lux. – Mohammad Dehghan Jan 26 '16 at 13:22
  • 1
    I just found the drupe contacts dailer app is causing the issue for me. – mangatinanda Jul 2 '16 at 3:59
  • 1
    Completely ridiculous...but it worked. – Erutan409 Jul 24 '16 at 22:55
2

There are three places to check. Not just one.

Non-system Apps

Settings -> Application Manager -> Apps with Overlay Permissions -> Apps with Permissions

System Apps

Same as above, but with Show System Apps turned on

Accessibility Apps

Settings -> Acessibility -> Scroll to the bottom. It lists app names. Just turn them all off for now.

http://www.renewandroid.com/phone-tips-and-tricks/screen-overlay-detected-170.html

  • The third ítem was the problem for me. Assistive Touch had to be disabled there. Great! – sancho.s Mar 4 '17 at 2:15
0

There are some apps that are handled as Accessibility Services, for instance, Assistive Touch.

You can find them under Settings -> Accessibility -> Services.

protected by Community Nov 25 '15 at 3:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.