I am having trouble trying to root my Acer Iconia A100 with Android 4.0.3. I have tried several rooting methods and they always fail.

I have the USB debugging enabled, and all the adblock or antivirus apps are off.

I've tried all of these:

Am I just missing a step somewhere?

Here is the report from the SRSroot app:

---= SRS One-Click-Root v5.1 =---

11:29:11 AM - Starting ADB Server..
11:29:16 AM - Manufacturer: Acer
11:29:16 AM - Model: A100
11:29:16 AM - Android Version: 4.0.3
11:29:16 AM - Build ID: Acer_AV041_A100_1.049.00_PA_CUS1
11:29:16 AM - Board ID: vangogh
11:29:16 AM - Chipset Platform: tegra
11:29:16 AM - Getting OffSets.. : 0xd9f0 0xaf47 (True) 
11:29:17 AM - Query Server for Best Method.. Found Rootkit: 4

    ----= Start Rooting Process.. Please Wait =----

11:29:17 AM [+] Testing exploit: root8 (please wait..)
11:29:39 AM [+] Executing root8 exploit Failed. 

11:29:39 AM Auto Root Failed on this device. :( 

11:29:39 AM Rebooting Device and try again... 

On the Kingo, when I run the Windows application to root the Android it always says that rooting was successful, but when I try to do anything that requires root (like installing busybox) on the Android, it always fails. Then when I restart the android the rooting is gone.

So, I can root it with Kingo, and if I use SRSRoot after that, it says the android is, indeed rooted, but it doesn't persist. When I reboot the Android then run the SRSrootkit then it sees that the Android is not rooted (even though it seemed to be before reboot) and it cannot root it itself.

Using the unlockr method, I find that the batch file reports mkdir failed for /data/local/tools, permission denied with subsequent permissions errors. And so that method is not able to get root either.

  • Maybe I need a driver of some sort? – bgmCoder Oct 23 '15 at 19:57
  • I have the adb driver installed on my windows computer, I can see it in device manager. – bgmCoder Oct 23 '15 at 20:40

I had similar problems with 4.0.3 and 4.1, but I fixed it with king root (note the lack of an 'o' after 'king'). It is one of those one click root methods, but it has served me well, and always resides in my toolkit.

Download link (XDA Developers) : http://forum.xda-developers.com/devdb/project/dl/?id=14576&task=get

  • When I install the package (xposed installer), it says, "The latest version of Xposed is currently not active. Did you install the framework and reboot?" Do I have to install something else? If I use that installer to "install/update framework" it says, "failed to get root access". – bgmCoder Oct 23 '15 at 18:43
  • I rebooted the device and tried the Xposed Installer again and it says the same thing. I belive I have tried this before and I got stuck here the last time, too. – bgmCoder Oct 23 '15 at 18:50
  • I am trying this one now: androidxda.com/download-kingroot-application - it is called KingRoot, as you mentioned. Okay, it says it failed. – bgmCoder Oct 23 '15 at 18:57
  • So I tried rooting with Kingo, which seems to provide a temporary root, and then to use the xposed installer to install the framework with root access. But the xposed installer says, "There seems to be a known issue ("Segmentation fault") with your ROM. Installing xposed might not work..." – bgmCoder Oct 23 '15 at 20:38
  • @BGM Im not sure then. – Dan Brown Oct 25 '15 at 12:10

I suppose that you might have CWM or TWRP preinstalled. If it is so then you have to find superSu apk file which is flashable. Some time before I was having same problem for 4.0.3. So just flash it in recovery mode and you will be enjoying the hidden power of android.

  • How can I tell if I have CWM or TWRP installed? I have the superSU apk file - how do I flash it? – bgmCoder Oct 23 '15 at 21:30
  • Boot into recovery mode. – Vivek Ji Oct 23 '15 at 21:33
  • So I just boot into recovery mode and run the package installer for supersu? – bgmCoder Oct 23 '15 at 21:36
  • All I can do is boot into the stock recovery mode with the dead robot. – bgmCoder Oct 23 '15 at 22:41
  • "I suppose that you might have CWM or TWRP preinstalled." -- and what caused you to assume this? – Firelord Oct 24 '15 at 5:20
up vote 0 down vote accepted

Well, I think I found a viable solution: Full root for A10x and A5xx ICS. Simple method.

They have a link to a tablet driver for the Acer Iconia A100. I think that is what I needed all along. I installed that on my PC and ran the script and it worked just fine.

I rebooted the Android and ran the Root Checker application and it reports that the Android is, indeed, rooted.

The solution was simple and it persisted after a reboot!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.