My android is 4.0.3 and is on an Acer Iconia Tablet A100. I have rooted it already using this process, and the rooting persists between reboots. I can confirm root access with the Root Checker app.

I have installed the Android SDK and it's required Java SDK.

When I run Droid Explorer I get this message:

Droid Explorer error

What do I do?

1 Answer 1


Disclaimer: I am the lead developer of Droid Explorer

The dialog is telling you exactly what the problem it. It isn't saying you don't have root, it is saying that it cannot start ADB with root.

The more information link takes you here: Droid Explorer permission denied when accessing root-only folders.

Or you can go right to get ADBD Insecure. The app will exit because you need to install that app first, then start Droid Explorer.

Ultimately, you will need to install ADBD Insecure, or a custom kernel that allows ADB to run in root mode, or you will have limited access to some folders on the device.

  • But I do have root. The applications on the android all request and use root permissions. Root checker confirms root. Droid Explorer is the only thing that thinks there is no root. On the Android, I can view any folder on the entire system with the file browsers on the device.
    – bgmCoder
    Commented Oct 25, 2015 at 15:20
  • 1
    Yes, I get that you have root. but you cannot start ADB in ROOT MODE unless it supports it, either with a custom kernel, or using ADBD Insecure. Running an app on the device that requests root is different than how Droid Explorer uses root. It requests it through ADB, and if adb does not run in root mode, it will not have access to folders that require root. Commented Oct 25, 2015 at 20:15
  • Okay, I'm starting to get it now, Mr. Conrad. Thank you for explaining.
    – bgmCoder
    Commented Oct 25, 2015 at 23:05
  • Well, I'm not sure how it worked... I clicked on "Continue and show more information" and it opened the thread on my desktop browser (like you said it would) and then it showed my Android device and I opened it just fine and can explore just like you'd expect.
    – bgmCoder
    Commented Nov 2, 2015 at 4:45
  • it will continue to function, for the most part. You may have some issues accessing folders like /system/apps/ or opening a shell with root access (you should still be able to say "su" in the shell manually though) Commented Nov 2, 2015 at 4:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .