12

I have a problem with my Galaxy S3 4G. It's currently all stock and running Android 4.4.4.

It seems the Wi-Fi will not turn off i.e. I can turn it "off" in the settings or notification bar, and this will stop Wi-Fi from being connected and device uses my mobile data instead, however in the battery menu the Wi-Fi is still being shown as on, even when it's turned off.

As you can see in the attached image, it's draining my battery really fast, and will only turn off when the device is in flight mode. I've checked and cannot see any rogue apps causing this, but after searching online and checking all option menus I seem unable to fix this problem.

Is there any way to stop this, save for a factory reset? Is this a KitKat wide problem, or just on my phone?

(Click image to enlarge)

IMG:

  • Possible duplicate of Why is my WIFI always on? – Firelord Oct 25 '15 at 2:25
  • Sorry, but the screenshot rather suggests your mobile network as the likely cause. See how it drains whenever the "network signal" shows yellow or red (bad or no signal)? And besides, WiFi was off multiple times (whenever the "bar" is black – though it rather looks like you've been in airplane mode then, as cell signal is also black then). – Izzy Aug 14 '16 at 15:57
15

This is a common misconception with Android. When you turn off Wi-Fi, Wi-Fi does not actually turn off. There is an advanced settings menu where you will find an option that either says Wi-Fi scanning or Wi-Fi always on. Google uses Wi-Fi points to determine the device's location without activating the GPS.

Turn Wi-Fi scanning off to fix this. You might want to turn off Wi-Fi while asleep while your at it. It's in the same menu.

(Click image to enlarge)

IMG: IMG: IMG:

Edit: In Android 6.0 (Marshmallow), this option has been moved. It is now located in Location > (Overflow menu) > Scanning (Thanks, nanny)

  • 5
    The location of this setting changed in Marshmallow (6.0). It's now under Settings > Location > (Overflow menu) > Scanning – nanny Sep 1 '16 at 14:15
-2

First reboot your phone! If this doesn't work you should try a factory reset. I would recommend some apps to disable your wifi but they are already disabled! So i believe it's a software bug!

  • This is a normal behavior of Android. – Ethan Z Oct 24 '15 at 22:15

protected by Community Aug 14 '16 at 15:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.