Just got the 5x, and loaded it with my favorite tones. Did the same thing I usually do with Android phones to set different tones for different app notifications, alarms, etc.

Phone either plays stock tone or no tone + vibration.

The files were pulled directly from my Samsung in .wav format and will play on the 5x via VLC just fine.

  • Where did you put the ringtone file on? It should be on /sdcard/Ringtones
    – Andrew T.
    Oct 25, 2015 at 13:43
  • 1
    Horrible answer. I shouldn't HAVE to move the file there. Numerous programs offer me the choice of setting the file as a ringtone. If that involves moving the file, that's their problem. When I click on "Set as Ringtone", it should SET it. Lots of people are suggesting this, but I've had three previous Android phones, and never once did I need to explicitly move a file to Ringtones.
    – Auspex
    Jun 4, 2016 at 20:29
  • btw, putting a file in /sdcard/Ringtones actually has no effect, anyway!
    – Auspex
    Jun 4, 2016 at 21:37

12 Answers 12


I had this issue, but only with the Alarm media files.

Use a file explorer, like ES File Explorer:

  • Using the ES File Explorer, navigate to the folder you have place your custom alarm media files.
  • Click on the file you want, and in the "Open with" prompt select "ES Media Player"

  • Open the menu in the top right, and pick "Set ringtone" (the entry with a bell icon)

  • In the dialog that appears, pick "Set alarm"
  • I tried several folder locations when my LG G4 got the Marshmallow update and nothing worked. This little trick worked great for putting in the alarm sound I wanted.
    – techturtle
    Jan 22, 2016 at 20:39
  • Works for me; the selected sound gets added to the list. Note that after you'll have to set it manually as ringtone/alarm.
    – dr_
    Dec 19, 2016 at 13:12
  • @dr01 That's what I thought happened last time I did this, but this time it automatically became my Phone ringtone.
    – Auspex
    Jun 12, 2017 at 17:03

Surprisingly, the analogous trick doesn't work with alarm tones. I added an alarm tone to /sdcard/Alarms but the alarm clock app doesn't notice it or add it to the list of available alarms on my Nexus 5x. (To be sure my Samsung audio clip was OK, I tested it by putting it into the /sdcard/Ringtones folder, where it works as described here by others.)

However, I have discovered a workaround for alarm ringtones: If you put the ringtone into /sdcard/Ringtones/Notifications/Alarms, it will show up in the list of alarm tones in the Alarm Clock application and can be used normally.


It was a permissions thing for me.

Upgraded no problem and it was all OK. Factory started and although I could see the file in notifications it wouldn't play as a message tone.

Settings, apps, messages, added storage to permissions.......happy me!

  • 1
    Please clarify. It is difficult to make out what you did axed how it helped you and how you think this can answer the question
    – beeshyams
    Feb 16, 2016 at 11:50
  • I had problems with chosing custom alarm tones on Marshmallow. They were chosable within the alarm tone list, but if i chosed them, the default tone had been set every time. With this hint i was able to fix it, because simply as it was, the storage permissions were not enabled. Therefore i went to settings -> apps -> clock -> permissions and enabled "storage". Now i can chose my custom alarm tones as it were on 5.0
    – mru
    Apr 29, 2016 at 10:44

You can try converting the same into *.mp3 and try again. Ideally you should be able to.

  1. Downloaded ringtone from zedge (mp3 format)
  2. Downloaded ES File Explorer from Play Store
  3. Copied ringtone from download folder and pasted into Ringtone folder
  4. Called myself from other phone to confirm

Worked fine on Nexus 5x.


What I did:

  1. Installed ES File Explorer App on Nexus 5X.

  2. Connected my Chromebook to the Nexus 5X using a USB cable.

  3. Swiped down from top of the Nexus, chose "File transfers" as the desired use for the USB connection.

  4. Waited for the Chromebook to automatically open a window that shows the Chromebook and the Nexus file folders. Had to wait for a few seconds for this window to automatically open.

  5. On the Chromebook, dragged the desired mp3 file from its Chromebook folder to the Nexus 5X folder named "Ringtones".

  6. On the Nexus, tap Settings> Sound & Notification > Phone ringtone. Nexus dialog asks which App to use, choose ES File Explorer.

  7. Tap on the mp3 file you want to use as your new ringtone.

  8. Close the Nexus Settings app, disconnect the USB cable, and you're done.


I copied the ringtone to ringtones folder on the phone. And when ever I want to change the tone in sounds and notification, that tone appeared along with the system tones. Simple isn't it?


I was having the same issue for notification tones and while troubleshooting it I happened to need to send a picture file over Google HO. The system prompted me to allow access to media (for the picture) and then suddenly custom tones started working. So you might try sending a pic in case this is a case of permissions not being set correctly by Android.

  • 1
    You don't need to send a picture, but the reason is plausible. It seems there's a "permission reset" bug for some people after updating to Marshmallow. Otherwise, just enable the permission from Settings - App - Hangouts manually .
    – Andrew T.
    Nov 11, 2015 at 4:39
  • Good info, Andrew, thanks. FYI, this wasn't an update for me, but a clean flash.
    – GPSRider
    Nov 11, 2015 at 5:25

I plugged Nexus 5x into my iMac. Used USB file transfer to move downloaded ringtone from download folder into Android ringtone folder. It then appears in the ringtone list under sounds in settings. Choose it and then it works fine. Double checked by calling my Nexus 5x from my landline.


Nexus 5X/Android 6.0.1

Android won't see new ringtones saved in the system ringtones folder (Android/media/com.google.android.talk/Ringtones) unless files are transferred to the phone via USB. If you transfer ringtone files to your phone from the cloud, FTP, or some other non-USB method you'll need to reboot your phone in order to see your ringtones using the system 'Media Storage' file picker.

In order to choose ringtones stored in a different folder using a 3rd party file browser such as Solid Explorer you first need to clear the system default 'Media Storage' ringtone file picker.

  1. click Settings, click Apps, click on the 3 dots upper right corner, click 'Show system'
  2. click 'Media Storage', click 'Open by default', click 'CLEAR DEFAULTS'

I've had this problem with my 6P. Even though my 3rd party .mp3 ringtones and notifications were stored in the Ringtones and Notifications folders (resp.) the Android Settings selection 'using Media Storage' would not display them (even after a reboot) and using the ES File Explorer option to select them gave "Wrong file type" errors. I couldn't set my Hangouts SMS notification to a 3rd party tone either. I also tried messing about with converting the file types with no luck.

I then followed the alternative method of setting ringtones and notifications from within ES Media Player described within this thread and it worked ...and I noticed that my 3rd party ringtone then appeared in the 'Media storage' list. Though I couldn't directly set my Hangouts SMS notification tone from within ES File Explorer I set my 3rd party notification tone as my general notification tone and then it appeared in the 'Media Storage' list in Hangouts so I then set it as my SMS tone and switched my general notification tone back to Tethys - job done.


Super easy way to do this (free as well)

  • send the .mp3 via bluetooth to your nexus 5x
  • download vlc player from the google play store onto your phone
  • play the .mp3 file with vlc player on your phone
  • from vlc there is a setting in the "kebab menu" to set as ringtone
  • 1
    Please link to play store app mentioned and adding a snap shot of "kebab menu" :) options would enhance value of answer
    – beeshyams
    Feb 17, 2016 at 10:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .