11

On my Nexus 5, since Android updated to , the Wi-Fi is draining the battery way too fast, even when disabled. See the screenshot:

(Click image to enlarge)

IMG:

I've seen this question: Battery drain when wifi is off but since I've a very stable network, the answer doesn't fit my need.

I've disabled the Location, I doubt that the issue could come from here.

Where should I look next?

Edit:

The real question is in fact "How come that the WiFi usage bar is going from 100% until now even if Wi-Fi is Off?"

12

Okay, to address the points here:

Marshmallow doesn't have the option of Scanning Always Available as it was in Lollipop.

So, what to do?

Marshmallow still has these options, only now they are fragmented and redistributed. It is now under:

  1. Settings → Google → Services → Location → 3-dot menu → Scanning → Wi-Fi scanning

Also, there are:

  1. Settings → Wi-Fi → 3-dot menu → Advanced → Keep Wi-Fi on during sleep

and

  1. Settings → Wi-Fi → 3-dot menu → Advanced → Network notification,

if you are paranoid about battery.

| improve this answer | |
  • Location>3-dot menu->Scanning is not available when location is disabled, Keep Wi-Fi on during sleep is set to something like Only while charging (don't know the correct english menu) and Network notification is disabled on my device... Any other place to look for? – Thomas Ayoub Oct 27 '15 at 10:34
  • Enable location to access the option. You never know, it might be the same case with location as it is for WiFi – Tamoghna Chowdhury Oct 27 '15 at 10:41
  • 1
    I've turned all if those off but it's staying on. Looks like a bug to me – ChrisFletcher Jul 3 '16 at 18:53
1

After doing everything tamoghna said, it may also be necessary do do the following (I had to on my moto g4):

  1. open the location menu
  2. click "mode"
  3. choose "device only" (gps only)
  4. turn gps back off because choosing this setting activates gps

The other modes use background wifi, as the menu explains.

| improve this answer | |
1

Little notice for AOSP Marhsmallow (and Nougat?) users: the "more" vertical button will not appear whatsoever in the Location settings page.

It can still be accessed from toggled-off WiFi and Bluetooth settings ones, but once their scan is both off (and the "convenience tips" aren't shown anymore) there's no other code in the UI to access ScanningSettings.

The only existing method (and necessarily from a rooted phone, since SubSettings is not callable from unprivileged uids since Lollipop) is using adb shell "su -c 'am start -a android.intent.action.MAIN -n com.android.settings/com.android.settings.SubSettings -e :settings:show_fragment com.android.settings.location.ScanningSettings'"

| improve this answer | |
1

This is most likely media related. Devices on the network can be too chatty and try to constantly discover things and speak to each other non stop, keeping the wifi awake and active.

Two big culprits:

  • Spotify (uninstall or restrict all background activity?)
  • Google Home devices like the Mini (turn off "Let others control your cast media")

Also check out,

Settings -> Google -> Security -> Find my Device

this might also be a suspect

and,

Settings -> Google -> Device Connections -> Devices -> Show Notifications When devices are nearby

And then also,

Settings -> Passwords & security -> Privacy -> Location -> Google Location history

perhaps this is also scanning


Background: I monitored the network traffic on the wifi network that the Redmi 6 running MiUi was connected to that has the drain issue. It seems to be communicating constantly with a random laptop over the network. It's keeping awake because of some Spotify traffic.
So I believe this is caused by media apps that try to do this whole shared network controls. It can be related to other media devices on the network too. There's a Google Home Mini on this network, which has this "allow other devices to control the media playback".

So turn off Spotify and Google Home devices and see if that helps. The network broadcasting features must be draining and always keeping things awake.

| improve this answer | |
0

This is what worked for me. I suspected the Wi-Fi was draining the battery way too fast because of an app called wireless update com.adups.fota. When I first got the phone it downloaded a large file and then restarted. If your phone is BLU, ZTE or Huawei but not limited to these brands, this is likely the problem. Apparently this is malware.

Here is what I did:

  1. Factory reset.

  2. Disable the above app (and rest of bloatware as well), but not through the settings as it will automatically be enabled again. You need adb shell. I followed these instructions: How to Uninstall Carrier/OEM Bloatware Without Root Access.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.