1

I have an international HTC One M8, and an off-contract plan with T-Mobile (highest priced, unlimited LTE).

If I go into settings and set mobile data to only use 2G, everything works reliably.

With either 3G or LTE, however, none of my apps can send or receive data most of the time. The notification icon reads "3G". Data is only transferred when it changes to "H+", which almost never happens to me.

What I've done so far:

I've gone into *#*#4636#*#* and switched between LTE/GSM auto, LTE/WCDMA/GSM auto, LTE only, and almost all the rest of them.

I've traveled in the States. I live in Puerto Rico, but I have been to New York, Washington and Baltimore with this phone and SIM card already.

I have tried APNs fast.t-mobile.com, fast.tmobile.com, epc.t-mobile.com, epc.tmobile.com, and even pcweb.tmobile.com.
I have tried combinations of APN types default, hipri, internet, admin, dun, mms, as well as leaving it blank / putting an asterisk.

I'm on a rooted phone with a custom ROM (Carbon), so I tried several different ROMs, both Lollipop- and KitKat-based.
(This is the only reason I haven't talked to T-Mobile reps directly yet, because this still might be an issue with the custom ROMs).

Symptoms are still the same.
Is it a known issue? What can be done?

0

For anyone experiencing this, it's very likely that your phone is intended for a different geographical region.
I will provide an answer for my own device, however the rationale and the process should hold true for other cases of this sort.

Mine was an Asian version that supports, at most, LTE bands 1, 3, 7, 8, and 20.
LTE in North America uses bands 2, 4, and 12.

A potential solution to get full LTE speeds is to flash custom radio firmware (at your own risk). I couldn't find a zip for T-Mobile, but the word is out that GPE radio firmware is the same.

A solution that gives you 3G (in my case) and doesn't involve flashing: go into *#*#4636#*#* and pressing the menu button in the top right. It opens a very old-school dropdown, and you can't really see which option is selected. Chances are, yours is in "Auto" mode. Try switching to particular bands instead. In my case, there was just one band in common between GSM 3G implementations for Asia and the US: PCS 1900 MHz.

Additionally, you may want to switch to "GSM auto," and in "Settings -> Mobile networks" to choose 3G as preferred rather than LTE. However, I haven't tested whether it makes any difference.

Most of the credit goes to the posters in this reddit thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.