0

I have a Samsung Galaxy Note 2 running the latest nightly of CM 12.1. I've installed the correct version of Gapps using OpenGapps Aroma installer. I have root disabled in developer settings, however, when I open Android Pay I get the following error.

Click on Image to enlarge
Android Pay is Unavailable

I looked up other ways to fix this problem on the internet but I could not find any solutions. The only other solution I found was to install the right version of Google Play store, but I also tried that to no avail.

Please let me know a way to solve this problem since I can no longer access the gift cards, loyalty cards, or credit cards I used to have on Google Wallet.

  • Try xposed module - RootCloak Related subreddit – Manubhargav Nov 2 '15 at 1:47
  • I have already tried hiding root using many different methods. RootCloak, however is not compatible with my device as there is not yet an Xposed Module released for my device. I still do not understand why disabling root using either the SuperUser app or doing it through the built in SuperUser settings inside developer options is not fixing the issue. – Kevin Rajan Nov 9 '15 at 21:27
1

Android Pay checks the operating system and if it's not stock Android, it will refuse to run. Some people have reported on that they have fooled the app into working by changing the default.prop file and others install a custom APK of the older version of Google Wallet. Otherwise, there's no way to run Android Pay on CyanogenMod or any other custom ROM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.