2

With ES File Explorer when I try and access my Windows 7 pc under LAN I'm greeted with the error "Login fail. This may be caused by: plain text passwords are disabled." I am sure the username and password entered when adding the server to LAN page are correct.

Login fail screenshot

How do I enable ESF to use encrypted passwords?

Failing that what do I need to do in Windows to make plain text passwords work? (not really desirable, but I need the ability to copy files to the pc more...)

1

Solution

Restart the Server (LanmanServer) service, restart ESF on the Android device, browse to LAN connection, done. Doesn't require plain text passwords or any other registry hack.

Make note of any dependent services that may also need to be restarted:

The following services are dependent on the Server service.
Stopping the Server service will also stop these services.

   Media Browser
   Computer Browser

Do you want to continue this operation? (Y/N)

On Android, make sure ES File Explorer is closed completely, not just exited (suspended). Samsung's [Close All] seems to be effective (don't remember the Nexus equivalent).

Interactively:

Start >> Run >> Services.msc >> select "Server" and Restart

Command Line:

Sc \\server stop  LanmanServer
Sc \\server start LanmanServer

Research

a.k.a sources a.k.a. other paths which might be fruitful for you if the above isn't.

Suggestion: Enable Plain Text Passwords in Windows

…you could attempt to enable plaintext SMB authentication just to see if it fixes your problem, though. Its unclear to me whether this would work on Windows 7 or not, but you could try setting the DWORD value "EnablePlainTextPassword" to "1" at "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters". Reboot (or stop and restart the "Workstation" service) and see what that does.

Check out Chris S comment below. It's very likely that the default LMCompatibilityLevel of Windows 7 (which is "3", meaning "Send NTLMv2 only") is causing your problem if your LaCie device is using an older SMB server (like a Samba version pre-3.0.21, for example).

From https://serverfault.com/questions/145666/how-to-enable-old-networking-protocols-in-windows-7/145675#145675

This is what I did last time this irritated me enough to do something. However when I checked that setting now, it's still set.

Suggestion: Reboot Server

…a dirty workaround: reboot your Windows file server. All your Android devices will immediately be able to connect again... for a time being. For me it usually lasts 1-2 days. Then SOMETHING happens - obviously on the Windows side, and it's again "login fails" from all Androids with ES, yet Windows machines keep being able to access all the shares.

From http://www.tomshardware.com/answers/id-2165494/connect-win7-share-android-fine-windows-machines.html

Suggestion: Re-enable SMB Protocol

I had the same problem and fixed it by reenabling the SMB protocol as described here: http://support.microsoft.com/kb/2696547?

To enable or disable SMB protocols on an SMB Server that is runningWindows 7, Windows Server 2008 R2, Windows Vista, or Windows Server 2008, use Windows PowerShell or Registry Editor. […] paste the following cmdlet into the powershell:

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB2 -Type DWORD -Value 1 -Force

and hit enter. Reboot.

From http://www.tomshardware.com/answers/id-2165494/connect-win7-share-android-fine-windows-machines.html

Suggestion: Enable Server File Sharing Mode

WIN7 machines when left on for a while, tend to have their shares just "disappear". There are registry setting that can fix this PC to PC problem […] in the release of WIN7. […] They changed the numbers in two registry settings, and that caused your PC-to-PC shares (in your home network which has no server) to disappear. […] By changing the registry BACK to normal settings, you essentially tell it to act like all the other versions of Windows did. The recommended settings for a machine that has shares in use, is

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache=1 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size=3

From http://www.tomshardware.com/answers/id-1938243/access-win-android-phone-wifi.html

An answer on Super User to Connect from Android (ES File Explorer) to Windows 7 Share suggests the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.