2

Using Ubuntu 15.10 I am not able to emulate an Android device using any x86 images.

The emulator starts but the screen stays black. Using an ARM image works.

From what I found it seems to be related to some 32Bit libraries missing. But I was not able to locate the missing once.

The log looks like this:

/home/christian/Android/Sdk/tools/emulator -netdelay none -netspeed full -avd Nexus_5X_API_23
emulator: UpdateChecker: skipped version check
  • Did you try re installing HAXM? – Fabin Paul Oct 30 '15 at 5:48
  • In the SKD-Manager HAXM is listed as not compatible with Linux. – Chris Oct 30 '15 at 9:30
  • you can try this link out.. – Fabin Paul Oct 30 '15 at 9:32
  • It fails on the step sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils ia32-libs-multiarch saying: E: Unable to locate package ia32-libs-multiarch – Chris Oct 30 '15 at 14:36
  • Ignoring the multiarch problem and just continuing with the guide I get this output trying to start a emulator: /home/user/Android/Sdk/tools/emulator64-x86 -netdelay none -netspeed full -avd Nexus_5X_API_23 -qemu -m 2047 -enable-kvm emulator: ERROR: Could not load OpenGLES emulation library [lib64OpenglRender]: lib64OpenglRender.so: cannot open shared object file: No such file or directory emulator: ERROR: Could not initialize OpenglES emulation, use '-gpu off' to disable it. – Chris Oct 30 '15 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.