So I have a rooted Lenovo P780 with VibeUI 2.0 KitKat, without google play services.

Some apps give the "Get google play services" popup, but don't actually need it. It's a bit annoying and I remember seeing an app someone made that disables that message. I remember seeing it on the xda-developers forums, but can't find it.

Does anyone have any idea where I could find it, or something similar?

I'm aware that such an app wouldn't fix anything, I just want to disable the message so I don't have to dismiss it every time. Especially since it pops up without warning, so I sometimes accidentally click it.


Here's one way that you can try and remove the Google Play Services dependency using Lucky Patcher. Install lucky patcher (a simple search should give you it), give it root permissions, and then you can do one of the following next:

  • Create a modified APK file which has the dependency removed
  • Or directly patch the app

Creating a modified APK file

Open up Lucky Patcher. Find the app you want to patch, tap on it, and select Open Menu of Patches. Select Create a modified APK file, then APK without licence verification. Near the bottom of the list there should be an option labelled Remove dependencies. Make sure that only it is checked (ie: all others are unchecked), and then select Rebuild the app at the bottom of the dialog. Wait until it's finished (it may take a while), and voilà, you'll have an APK which shouldn't require Google Play Services. With this method, chances are you'll have to uninstall and reinstall the app with the custom APK, thus loosing all data (unless you somehow back it up).

Directly patching the app

This method is (probably) simpler and doesn't require you to uninstall or reinstall anything. First, if your app has been moved to the SD card through the normal method through settings, move it back to internal storage. Next, open up Lucky Patcher like the above instructions, and find your app. Tap on it, select Open Menu of Patches, then select Remove licence verification. You'll want Auto Modes here, so select that. Now check the Remove dependencies box and make sure any others are unchecked (however, if you want to, you can select Backup APK file in case something goes wrong, because then you'll have something to revert to). Select apply, wait for it to finish (again, it might take a while), and there you go, you should be done.

  • My root is messed up I think. The app fails to get root permissions for a lot of commands. Originally I tried rooting using this tutorial, but I couldn't get the flashtool to work, so I eventually ended up using Kingo root. I'm pretty sure there's something wrong with the binary end of the su... When I installed TWRP recovery using mobileuncle tools, I could only access it by rebooting into it, but if I shutdown first it just goes to the Chinese stock recovery. (cont.) -> – 1N07 Nov 5 '15 at 2:19
  • -> I mention that, because that certainly isn't normal and I don't see what else would be the point of failure, but the su root. I've had problems with root permissions on some other apps as well, but then others work just fine. – 1N07 Nov 5 '15 at 2:26
  • @1N07 Have you tried flashing something like SuperSU through recovery? It's probably the widest used root management app out there, but I'm not sure what would happen if you over rooted the kingo root. Recovery should always really be installed from a PC using fastboot, and then stuff flashed from the recovery when you need to. – Joe Nov 5 '15 at 11:05
  • I seem to remember trying that as well and not getting it to work, but I'll try again at some point – 1N07 Nov 5 '15 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.