When I plug in my Samsung Galaxy S (Model SAMSUNG-SGH-I897, Firmware 2.2, Kernel, Build FROYO.UCKB2) to a computer, it starts charging, but does not recognize the USB connection for data. I have tried toggling debugging, mass storage, and ask on connection, but all that happens is that it draws power. I've tried both Windows 7 32bit and Ubuntu 11.04 32bit. It was working yesterday.

Additional note: dmesg, lsusb, and adb do not recognize the device at all under ubuntu



3 Answers 3


This has happened many times to me, and every time it has been a bad cable. If you have one, try finding another USB cable to test it with, and see if it works. Often some connection goes bad in the cable just from use and wear and it will only charge and refuses to transmit data.

The other possibility (this is known to be a problem with the EVO 4Gs, but i don't think i've heard of it on the Galaxy S) is that the USB port on your phone has been damaged or gone bad. This happened to my dad's phone (EVO) and they sent him a replacement.

Let us know what happens after you try a new cable!

  • I'll try to find a different cable (not at home at the moment), and it shouldn't be a warn out connect, the phone's only a month old!
    – bheklilr
    Aug 25, 2011 at 17:26
  • My dad's went bad after about a year i think. but i've flown through cords, especially after buying super cheap (3 for $2) on Meritline :P Aug 25, 2011 at 17:48
  • There are many reports on the net that describe this issue: Only charging works but no USB data connection. A friend of mine had this also. Besides a bad cable I think that its also a manufacturing/desgin flaw. Try sending the phone in.
    – Flow
    Aug 25, 2011 at 18:17
  • @jlehenbauer I tried a different usb cable, and it seems to be an issue with the phone. I'll try a couple more cables before I RMA it, and I'll try to clean the contacts too. Thanks
    – bheklilr
    Aug 25, 2011 at 21:27
  • sounds like a plan @bheklilr. let us know what works and what doesn't, as this sounds like a common issue Aug 26, 2011 at 0:20

Happened to me on Windows 7 and downloading drivers from Samsung's website fixed it: http://developer.samsung.com/technical-doc/view.do?v=T000000117


I discovered I did not have the tethering turned on ,on my phone , when I tried again it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .