0

Android sometimes has this strange habit of not automatically reconnecting, when it looses connection to the router. I have an Android tablet running 24/7 using a bot to do stuff on the Internet. But sometimes, the connection breaks, and i have to manually click on the wlan symbol in the dropdown thingy the force android to reconnect the the router. This is annoying, because I have to check multple times a day, whether the bot is still working and reconnect if not.

This happens approximatly once/twice a week. I'm using a Samsung Galaxy Tab SM-T230, Android 4.4.2

Does anyone know how to fix the problem/why android does that?

0

You may be able to fix the problem using Tasker (paid; 7 day free trial) or MacroDroid (free/paid) or AutomateIt Pro and I don't have a reliable way to test my answer so I can't fix some flaws.

MacroDroid

The macro would be:

  • Trigger: Wifi State Change → Disconnect from Network → select your network
  • Action: Wifi Configure:

    • Connect to Network → select your network

    or

    • Disable Wifi
    • Enable Wifi
  • Constraint:

    • Wifi State → Not Connected to Network → select your network

    and

    • Wifi State → Wifi Enabled

Tasker

Profile would be:

  • Trigger: State → Net → Wifi Connected → check Invert
  • Task: Action(s):

    • Net → Wifi Net:

      • Action: Reconnect
      • check Force

    or

    • Net → WiFi → Off
    • Net → WiFi → On
  • Additional trigger: Net → Wifi Near → select SSID of your network

AutomateIt Pro

The free version requires me to connect to internet (which I'm unwilling to) to unlock a feature, so perhaps, free version can also do the job here.

The rule would be:

  • Trigger: [Composite AND Trigger]:

    • Wifi Network Connection State Trigger:

      • Monitored Network: select your network
      • Connection State: Disconnected
    • Wifi Network Available Trigger:

      • Network Name: mention the SSID of your network
      • check In Range
  • Action: [Composite Action]:

    • Set Wifi State Action → Wi-Fi Disabled
    • Set Wifi State Action → Wi-Fi Enabled

That should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.