I received a Samsung GS5 as part of a program from Samsung in exchange for their recording device statistics through an app I installed. The program is over, and I have been notified that the app can be removed, but whenever I try to uninstall it I'm told that the app is a device administrator and therefore can not be removed.

I tried to remove the administrator status from the app (it's called Samsung Insights) but the option is greyed out. Does anyone have another method of removing admin status or uninstalling apps that have admin status?

6 Answers 6


Go into your phone's Settings and open Security. From there, tap Device administrators, and you should be able to turn it off from there.

  • 1
    The OP clearly stated that he already attempted this and it is blocked from this menu.
    – Ethan Z
    Commented Nov 5, 2015 at 23:14
  • 2
    @EthanZ, the way I understood the question, the option is greyed out inside the app menu while the poster here is talking about Settings -> Security -> Device Administrators.
    – Firelord
    Commented Nov 5, 2015 at 23:17
  • Eh. Now that I look at it again, its hard to tell where he tried it. But in case it is grayed out, wouldn't ADB do the trick?
    – Ethan Z
    Commented Nov 5, 2015 at 23:20
  • @Firelord i was correct. The option to disable decice admin is grayed out in the device admin section of settings according to an answer that should have been a comment
    – Ethan Z
    Commented Nov 6, 2015 at 3:46

From Task manager go to downloads and click to uninstall. That should again lead you to device manager option of manage device admin apps and it may be possible now to see the option not greyed out

Another option if rooted, is to delete folder named after the app in /data /data. Next, search for apk file in device /system, delete it and reboot

If this doesn't work you could try uninstall through Titanium

  • 1
    This will not work. The restrictions are locked into knox and kernel, and uninstall will just remove the app, not remove the rest of the restrictions, if any.
    – Mike N.
    Commented Oct 3, 2016 at 7:02

That app is using the Samsung Knox api, which cannot be disabled by you. You need to reach whoever installed it and ask him to enable you permission to deactivate device admin. Another option would be wipe, if that is not locked too. You can check that by going into Setting - Backup and reset. If its grayed out, there is nothing you can do.

AS EXTRA, i can say the samsung api can lock device admin removal, factory reset from system and recovery and also flash through download mode and also safe mode.

I am using the same api in some of my apps and i know what that means. I cannot show now the link to it as Chrome is freezing on mobile. Will do when i get to my pc.


public boolean setAdminRemovable (boolean removable)

Usage An administrator can set their removable status. If set to true, the user can remove the administrator through the Settings application. If set to false, the user cannot remove the administrator through the Settings application.



IF you can not deactivate a device administrator boot into safe mode. And try it I am pretty sure it will work and then you can uninstall it.


I had the same issue on a 7s edge with the latest Nougat update. Fixed the issue by resetting all settings. After that everything worked fine. No need for factory reset.


Samsung Insights app is required to participate in the Samsung Insights program (latest equipment at a 50% discount, etc).

You normally run it for 6-months to a year. At that point, you have a Contact Support link you can press. If you've run the app long enough to qualify for deactivation, it'll provide you with an e-mail link. Click on it, go to your mail program, and send the message out.

They should send you back a code you can input to deactivate.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .