2

I read all other questions of "Insufficient storage available" but none of solution works for me.

I have Samsung Galaxy S3 (GT-I9300). I have 5GB free space on internal memory. A couple days ago WhatsApp and Viber were gone (In the application manager instead WhatsApp I saw com.whatsapp.. same for viber- saw the package name and the two apps's size is 0)

I tried the following solutions:

  1. Clear cache of google play store, services, and also clear updates of those apps.
  2. Got root access and delete com.whatsapp-2 folder from /data/app-lib as described at XDA
  3. wipe cache partiotion via recovery
  4. clear dalvik cache
  5. Download manually the apk from whatsapp.com and not from Google Play
  6. Backup WhatsApp from other device and restore with titanium backup to my device -same error...
  7. change default install location with pm set-install-location to 0 then 1 then 2. none worked.
  8. Deleted cache of all other apps in the device.

I can install any other application from Play store, just viber and whatsapp causes the "Insufficient storage available" error.

I don't want to do factory reset. Could you help me and suggest another solution, please?

0

Maybe you should try to install or update the app with the apk you just downloaded from a mirror with adb and then you should know if any package installer is having trouble. Samsung devices have always given me some trouble concerning storage issues. If that does not work you can always try the old fashioned kinda noob way by installing some Cleaning app and see if it can solve any cache issue.

  • The question has been edited to indicate that your solution does not work for the OP. Please update your answer to reflect the same. – Tamoghna Chowdhury Nov 6 '15 at 15:36
  • thanks, tried this also before asking, didn't work- same error – Ben Nov 6 '15 at 16:08
0

My only suggestion to overcome all these issues regarding sdcard space management on Samsung device is to revert to custom rom, Lollipop 5.1 as I did. You wouldn't ever more experience such stressful situations. Try Archidroid-3.1.5, great ROM for s3 gt-i9300.

0

Have you trimmed (applied fstrim to) your device's partitions? If not, access the Android shell and then run these commands:

  • Become root:

    su -
    
  • Trim the /data partition:

    fstrim -v /data
    
  • Trim the /cache partition:

    fstrim -v /cache
    
  • Remount /system as read-write:

    mount -o rw,remount /system
    
  • Trim the /system partition:

    fstrim -v /system
    
  • Reboot your device:

    reboot
    

In order to run these commands as root (the "superuser"), you have to have rooted your device and need to have a previously-installed terminal emulator. If you don't have a terminal emulator, you can alternatively use ADB (Android Debugger) after you install it on your computer. If you don't have ADB yet, install the Android SDK Tools Only. After you install it, access its folder and you'll find a platform-tools folder where the ADB executable binary file (adb.exe, in Windows, or adb, in Linux/OS X) is available.

If you intend to use ADB, use a USB cable to connect your Android device to such computer where ADB is installed, then go to your Android Settings, Developer Options, activate USB Debugging, afterwards run your computer OS's shell (Linux / OS X) or "command prompt" (Windows), use it to access the folder where the ADB executable binary is present, then run ADB followed by the shell word:

adb shell

Now that you're inside the Android shell, you can run all the commands mentioned before (su -, fstrim -v /data et cetera).

If you don't have the fstrim binary, you can run the Android package manager (pm) in order to trim the caches:

pm trim-caches    

...or, alternatively, you may want to try manually installing the Trimmer app (see the footnotes).

If this doesn't solve your issue, you may want to go back to /data/app-lib and delete all the other duplicate folders (not only Whatsapp's) except those with the bigger number. Example: if inside /data/app-lib there are the folders com.waze-1, com.waze-2 and com.waze-3, you have to delete com.waze-1 and com.waze-2, but do not delete com.waze-3. Repeat these steps for every appication folder under /data/app-lib.

After deleting all duplicate folders, restart (reboot) your device and run Google Play Store app again. Did it fix the issue?

If you're still experiencing the issue, go back to the terminal emulator or ADB shell, become root again (su -), then run cd /data/app-lib and finally run this command in order to recursively fix ownerships:

chwon system:system * 

Now restart your system (reboot) and cross your fingers. Sometimes another app messes with the ownership of these folders, hence making system their owner and group fixes the issue.

Good luck.


Footnotes:

  • If you don't have fstrim in your Android system, you can download Trimmer (com.fifthelement.trimmer-1.apk) straight from my OneDrive and then install it manually. The manual installation doesn't require the Google Play Store app, but you'll have to go to Settings, then Security, and then activate the Unknown sources option. After you do this, you can use any file explorer on your rooted device in order to access the folder where you downloaded com.fifthelement.trimmer-1.apk to, then touch the file and install it.
  • If you're in terminal emulator (or ADB shell) and you're already connected as root, you can cd into the folder where you've put the com.fifthelement.trimmer-1.apk file and then run this command:

    pm install com.fifthelement.trimmer-1.apk
    

    ...in order to manually install the APK using Android's package manager (pm).

  • You can then use the GUI (graphical user interface) of Trimmer in order to trim the /data, /cache and /system partitions. However, because /system is mounted read-only, you need to first go to shell, become root (su -) and then run mount -o rw,remount /system in order to make /system read-write. Only after doing so, run Trimmer and select all the three partitions for trimming.

  • Do you've busybox installed? Stock Android doesn't seem to ship with fstrim binary. toolbox and toybox doesn't have that utility. – Firelord Jan 13 '16 at 2:41
  • 1
    @Firelord Yup, I have both Busybox and Trimmer installed. However, if you don't have fstrim you can connect to the Android shell, become root (su -) and then run pm trim-caches – Yuri Sucupira Jan 13 '16 at 4:44
  • 1
    @Firelord ...or you can alternatively download the file com.fifthelement.trimmer-1.apk straight from my OneDrive (see my answer's footnotes) and then manually install Trimmer. I'm assuming that by using this method it will be possible to install the APK, because it doesn't require the Google Play Store app. – Yuri Sucupira Jan 13 '16 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.