I can't obtain an ip address to my Android smartphone from my wifi router. Observations:

  1. The smartphone connection to other routers or thru cellular data is ok.
  2. My router's wifi connection to my PC is ok.
  3. Wifi link to the smartphone was ok till recently.
  4. Security on or off doesn't make a change.
  5. Router is TPink WR541 v7. Firmware upgrade did't help.
  6. Problem persists with 802.11g or b.

  7. Message on the Smartphone: "Obtaining IP address from [My Router'a Name]". Then "Disconnected"

  8. Message on the router's syslog: "0334:DHCPS: 1:[PHONE's MAC ADDRESS], NAK in request."

    Would be grateful to receive your help. Best Regards, Joseph.

  • 1
    Any chance you have MAC filtering on? Have you tried changing the channel? – Matthew Read Aug 26 '11 at 15:24
  • MAC filtering is disabled. Tried to change the channel. Signal is very strong anyway. – user7586 Aug 26 '11 at 21:04

DHCPNAK is a server message, it's invalid for clients to send it. Sorry I can't be more helpful, not familiar with that particular router. I would recommend turning off encryption (briefly!) and sniffing the dhcp handshake with e.g. Wireshark and look at what's really going on.

As an aside, DHCPNAK generally gets sent (by the server) when the client requests renewal of an invalid ip, to trigger the client requesting a new address. Check that you have a dhcp pool configured and that it has not been exceeded. Still shouldn't kick out that error, but something to check none the less.

  • +1 for the wireshark idea. This will show what's really going on. – Flow Aug 29 '11 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy