0

I am using Samsung S6 and I installed Google Keyboard on the device.

When I was using Google Keyboard on Nexus device, it was logged into my Google account. On Samsung, if I go to Settings -> Language & Input -> Google Keyboard -> Accounts & Privacy, the Change Accounts preference there shows No accounts selected and does nothing upon tapping.

Is there a way how to make it log into my Google account so that I can sync my dictionary and use other functions of Google Keyboard only available when logged in?

0

Try this solution:

  1. Open up your Settings
  2. Navigate to Accounts
  3. Click on Google
  4. If you have multiple google accounts, find the account which you would like to use
  5. Tap the account you would like to use
  6. Now enable sync for the following things:
    1. Sync App Data
    2. Sync Google Keyboard (if you have the option to)
  7. Reboot
  8. Go to Google Keyboard settings
  9. Sync, and have fun

Add a comment below if you have any questions, or require further assistance!

  • I went to the options as described and everything was already on in there. There was no Sync Google Keyboard option. In Google Keyboard settings, there is still no account connected and thus sync doesn't work. – josefec Nov 7 '15 at 9:55
0

Same issue here but i got it to work on an S5.

Where you set up the account for the keyboard (the Change Accounts above), long press for at least 5 seconds then tap on Sync Now, you will then get a dialog asking for permission. Say yes obviously and then select the account...

Hope this helps.

  • Unfortunately, nothing happens when long pressing the Change Accounts and no dialog appears after tapping on Sync Now. :( – josefec Dec 30 '15 at 17:31
0

Dunno if you found the solution yet or not, but I had the same problem and solved it using the following method (found on a forum, cant remember where):

Go to Settings -> Language and input -> Google Keyboard -> Accounts & Pricacy

Click/toggle "Google Keyboard Sync" repeatedly (10-20 ish times) until a dialogue box pops up and asks you to choose account.

Really weird, but works.

0

For Galaxy S7, instructions from this post worked for me:

If you use Google Keyboard you might find that the the sync is greyed out under Languages & Keyboard - Google Keyboard - Accounts & Privacy. To fix this you need to go one page back and click on Text Correction and scroll down and make sure Suggest Contact Names is on. Go back to Accounts and Privacy and sync should be turned on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.