3

With Google's new policy of issuing monthly security updates to Nexus devices going on from Marshmallow, me, the proud owner of a Nexus 9 (16GB,WiFi, Build version: MRA58K), has to dirty flash all the factory images every month just because Google issued a 4.0MB update, and I had to connect my tablet to WiFi just because I needed it.

Rather, I prefer to go manual and flash factory images to upgrade between major releases, and ignore those which come in between. So, these monthly OTA updates are a nuisance, even if all I have to do to not install it is ignore the notification it poses. The nuisance being that I have TWRP, root and ElementalX, and prefer to use OfficeSuite over Docs and have no use for Fit - hence I've uninstalled (removed) those system apps, which makes the updates unable to install anyway.

So, the question:

What service(s) or process(es) is/are responsible for downloading this update? Which app are they a part of? And, most importantly, Can I Disable the offending app/process/service without otherwise affecting my system? (That includes interfering with GAPPs in any way)

NOTE: I know the notification is presented by Google Play Services, I checked that. I want to know what processes/services are responsible for downloading the update, not showing the notification.

Edit:

For all those voting to close the question as a duplicate, I have not encountered an answer which satisfies my requirements in the referenced question which this has been thought to be a duplicate of. For future notice, I not only wish to disable the notification, but the updater service as well. Also, the answer provided in the linked question will potentially affect other components of my system, not just the OTA Updater, as it involves disabling all or just notifications from "Google Play Services", which is not at all what I want (I understand what that app is, and disabling any part of it is not in my best interests. So, anything not involving GAPPs is a better solution (since I am heavily dependent on them, excepting the Docs suite).

Edit:

I had since moved on to the PureNexus ROM and rid myself of these issues. Now I have manually upgraded to Android 7.0, and I don't use the device as much anymore. So these answers are not applicable to me any longer, but this question is a good reference point for others with a similar concern.

  • Possible duplicate of How to get rid of OTA software update notification? – bmdixon Nov 9 '15 at 9:54
  • I don't understand why you would want to hunt down the service/process responsible for downloading the update. Even if you come to know if it, there is no guarantee that you would be able to safely disable that service/process without risking the stability of Play services. I suggest you try NotifyClean instead. Rather than opting to disable all notifications from Play Services you can choose to hide only a particular one (in this case, the one about system update). I successfully use this module in Android 6.0.1. – Firelord May 20 '16 at 5:20
  • @Firelord Perhaps you might want to make that an answer? //I wanted to disable the OTA Updater process so that the OTA updates wouldn't download at all - let alone show a message. I accede to your second point, however. – Tamoghna Chowdhury May 20 '16 at 13:50
3

Rename /system/etc/security/otacerts.zip to otacerts_bak.zip.

This will prevent it from communicating with the OTA update server.

  • you will also need to update your answer - the user must mount the /system partition in order to move the file. Follow the instructions here android.stackexchange.com/a/110928, and then run mv /system/etc/security/otacerts.zip /system/etc/security/otacerts_bak.zip – niftylettuce Oct 15 '17 at 9:55
1

Sorry, I don't have Marshmallow available to confirm the process 100%. That being said, the standard method for several versions of Android has always been the following:

  1. Goto Settings
  2. Scroll all the way to the bottom & find "About (... | phone | device)"
  3. Find the "Update" | "System update" option
  4. Disable "auto download" | "auto update"

Simple instructions with screen shots are available from WikiHow.

  • 2
    I don't have any options (no 3-dot menu, nothing) under System Update. However, I accepted your answer because otherwise it is probably the correct process to go about achieving this. – Tamoghna Chowdhury Nov 9 '15 at 16:02
  • 1
    Or, rather, the problem may be on my end. I already have the November 2015 security patch "downloaded and ready to install", so that may have something to do with me not getting any of the options you mentioned. I'll confirm and report. Thanks anyway. – Tamoghna Chowdhury Nov 9 '15 at 16:03
-1

I bought a Nexus 6P and activated the service with Sprint. The problems was, a few months ago one of Google's updates has a bug that won't allow me to get LTE service with Sprint (fixed now). So what I had to do what revert my android phone to a previous version and not update my phone until the patch fixes the problem.

To go along with you problem, it annoyed me because after reverting to a previous version, I would constantly get these notifications to update my phone which I didn't want. Here's what I did to get rid of these notifications:

Go to Settings → Apps → Google Play services → Notifications → Block all.

I re-enabled it recently because it seems Google fixed this issue.

  • I solved my problem by jumping to PureNexus XD - Not going back to stock ROMs again :P – Tamoghna Chowdhury May 19 '16 at 18:13
  • I'm downvoting your answer as I specifically mentioned in the question that I couldn't disable Google Play Services notifications, and answers mentioning that weren't welcome - Read the part in bold. IDK who upvoted your answer - but he/she shouldn't have done so without reading the question. – Tamoghna Chowdhury May 19 '16 at 18:16
  • The solution I provided does answer the question "How can I disable automatic OTA updates on a Nexus device on Marshmallow?". Disabling Google Play Service notifications will stop asking you to update your Android OS unless if you go to the 'System updates' in the About Phone section. Even though you disabled the notifications, this does not mean your Google Play apps won't get updated. It might be better for you to Google how OTA updates work instead. Either way, I'm glad to see your problem was solved. – MB41 May 23 '16 at 18:34
  • I'm sorry, I guess you misunderstood something. I wanted an answer that had nothing to do with Google Play Services, period. That was the reason I downvoted your answer, and also it was because the solution you suggested was something I had tried already and did not want to try again, and which had been mentioned to that effect in the question itself, so your answer adds nothing much of value to this entire discussion. In fact, the Possible Duplicate comment's linked question below my question has an answer which is equivalent to your suggestion. – Tamoghna Chowdhury May 24 '16 at 17:09
-1

Enable Developer Options In Android 6.0 Marshmallow 1. Pull down on the notifications shade and open the Settings app. You can also achieve the same thing from the app drawer if you so wish.

  1. Scroll all the way down and tap on ‘About phone.’

  2. Now scroll down again and you’ll see an entry labelled ‘Build number.’ Keep on tapping till you see a prompt that says ‘You are now a developer!’

after on this option you can Automatic System Updates toggle is set to off, for get rid of this stupid automatic System update.

  • There is no such option anywhere in settings. Please tell me which device you are talking about, and where this setting is located, preferably with screenshots. – Tamoghna Chowdhury Feb 4 '17 at 18:35
-1

Deepak has correctly answered the question, however, has not been clear enough. To clarify: go to "Settings", "About", and tap on "Build Number" until you see the message "Developer Options has been turned on" (or similar) - requires 7 taps usually. At that point, GO BACK to Settings main screen and scroll all the way to bottom, where you will now see "Developer OPtions". Under this (new) set of options, find "Automatic System Updates" and turn it off. This should resolve the problem, though not sure about the notifications, but my quess is that will not pop up anymore, since you have disabled the functionality that causes it.)

  • You have not answered the question I commented below @Deepak's answer - what phone are you talking about? That's important to know, different manufacturers organise their settings differently, and it's different in different versions of Android. Anyway, I run stock 7.1 on the device now, and this "Automatic System Updates" option doesn't exist there. I do know how to enable Developer Options, so more information regarding that isn't required. (There's a tag wiki on this site for Developer Options, it can be linked of necessary). I've in fact mentioned in the question that my device is rooted. – Tamoghna Chowdhury Jul 15 '17 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.