I installed Z4root on my Galaxy S (the original, not the S II) after reading this post, using the APK file attached to the post (can't find it in market). The thread leads me to believe that the process is as simple as installing, switching USB debugging on and pressing the root button. Not in my case.


  1. First time, the app didn't get further than the "running root exploit" message (waited 30+ mins)
  2. After rebooting the phone out of desperation, when I press the permanent root button it gets as far as the "acquiring root shell" message and the app either just disappears (with no results) or the app stops working and I get the force close window.

I've tried this many times with reboots in between, both plugged in and unplugged and no different results. Do later SGS models have some anti-root hax built into them? Have I missed something obvious about the process?

Extra info:

  • The phone does not have three button recovery mode
  • The author of the app claims to be from the same country as me, and his phone is also SGS running Froyo. If we are cursed with weird "international" hardware I would've expected the same to happen to him.
  • The thread talks about a superuser app being installed after the phone reboots. I already had Superuser installed (but never been able to use it because I haven't successfully rooted ever). I uninstalled the app and tried z4root again, but nothing different happened.
  • The thread suggests using adb logcat to get debugging info, but logcat spews an endless stream of info that is much longer than the examples I've seen in the thread (long enough that my terminal buffer loses the top info before it finishes). What I can see doesn't seem like it is related to z4root.
  • How do you know your phone doesn't have a recovery? Can you get it into Download Mode? Are you opposed to flashing a pre-rooted ROM (can be just stock+root)? Aug 27, 2011 at 21:30
  • I know that it doesn't have three-button recovery (are there other types?), because I've tried rebooting with the appropriate buttons, and it does nothing differently. Apparently this is the case with some of the international variants. Hadn't heard of Download Mode but followed these instructions and it didn't work either: samsunggalaxysforum.com/samsung-galaxy-s-rooting/… Re Flashing: not opposed to anything that I can see step-by-step instructions for and which has been around for long enough for people to comment with any problems they've had. Aug 27, 2011 at 22:01
  • Related: How do I root my Samsung Galaxy S?
    – Izzy
    Feb 6, 2013 at 14:14

2 Answers 2


That wasn't working for me neither, but when I tried the SuperOneClick it worked perfectly and very stable, but you will need to use a PC to do it.


If you've got a Galaxy S without a three-button-recovery mode, have you looked into making or buying a download mode jig? See this post for instructions on making one, or there are a few eBay sellers that stock them pretty cheaply.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .