2

It seems when access to Google's servers is blocked (by a firewall for example) Photos doesn't display my photos. The photos are locally available and can be browsed with a file explorer app. I don't want all my photos stored in the cloud nor do I like the idea that Google is checking something every time I open the Photos app. Is there a workaround to disable this behavior?

Edit: The bounty auto-selected an answer but the answer does not work. This is the main "Assistant" view: photos This is the device folders view: device folder

  • Assuming your photos are in some standard format like jpeg? – jiggunjer Nov 21 '15 at 2:40
  • Did you already clear app data? – Hayden Moulds Nov 28 '15 at 15:52
  • @HaydenMoulds there is no clear app data option for Photos on my system (Marshmallow). – Reed G. Law Nov 29 '15 at 23:26
  • I just checked on mine and I have it. Do you have a custom rom? On vanilla android once in app info the clear data option is in the submenu option "Storage". – Hayden Moulds Nov 30 '15 at 23:31
5
+25

Even thought the photos are stored locally, when in the main view of the photos app only the thumbnails or nothing at all (if thumbs are not cached) will be shown when internet is off/blocked/limited.

The only way you can access the local copies while using the photos app is to open the menu on the left and select "Device Folders" and then go into the Camera folder (or wherever it is you are trying to access).

Click Images to enlarge

Select Menu, then device folders option

Choose the folder that contains the photos you are looking for

Unfortunately because the internet is limited you wont have access to the nice new features such as the advanced photo search or the nice date order layout as these are all server-based features.

  • I've tried the Device Folders view but the thumbnails were all grey and the pictures wouldn't show either. The only thing that worked for me was opening the photos through a 3rd party file explorer. I'll try it again though. – Reed G. Law Nov 18 '15 at 1:31
  • That is in fact the standard procedure, even if it doesn't work for the OP. So +1. – Tamoghna Chowdhury Nov 18 '15 at 14:24
  • If it still isn't working, try clearing the data for photos in the android settings > apps > photos area. – Hayden Moulds Nov 18 '15 at 14:39
1

You can check if the photos are locally stored or not by:
PhotosSettings → Uncheck Show your google drive photos & videos

If your photos do not show now they were never on your device. To store them on your device download them from Google Photos and also turn off Backup & Sync if you don't want it.

  • This setting was already unchecked. – Reed G. Law Nov 22 '15 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.