There's a long-running issue with Skype for Android where, in recent versions (since 2014 I believe), it very often ignores incoming calls and doesn't notify about messages when it is running in the background. There are many long (and often angry) threads about this on Skype's forums, for example: No incoming call and chat notification on Android KitKat (12 pages), Skype never rings on Android phone (9 pages), skype not running in background anymore? (4 pages), and many others.

From these threads I've extracted some clues:

  • It used to be possible to fix this issue by downgrading to before version 4, but older versions now no longer connect, so this appears to be no longer an option.
  • There is some mystery about why this happens, but there are claims that it's something to do with Skype's status changing to some kind of "inactive" status when it goes into the background after a period of inactivity (some sources say 15 minutes, some 5 minutes, some immediately on the Skype app window not being open), which, recently (but not in the past) results in Skype centrally not connect calls or messages to this user when this status is present.
  • If this is the case, it happens even when the optional Skype notification tray status icon shows the status as being "active" - some comments suggest this icon doesn't update when Skype becomes inactive in the background
  • There's a separate issue where Skype doesn't notify on a phone if you're active on a computer, but plenty of people report this problem even when they've confirmed they're only logged in on Android.
  • There's a post from 2014 which suggests that background calls work if "Answer calls automatically" is ticked in Skype settings - but I don't like the idea of people calling me and instantly hearing the sound of the inside of my pocket (maybe I've misunderstood what answer calls automatically means?), and I imagine I still wouldn't know they've called unless I'm in a silent room
  • A few users mention that turning on "sync group chat in the background" in notifications fixes notifications for calls and messages too (example) but this didn't work for me
  • A minority of posters claim to not have this issue, suggesting there might be something to do with general Android settings that influences whether Skype becomes unreachable when it goes into the background.
  • There's mention of 3rd party apps that fix this problem by keeping Skype active, thus preventing the status change. However I couldn't find any such examples that wasn't followed by a comment later suggesting it no longer works (and I can't find any examples now I look for it).

I've discussed this with Skype customer support, who were unable to help beyond establishing that it's nothing to do with my Skype app settings (notifications are on) or being logged in on another device. My main hope, therefore, is for some kind of 3rd party solution like the apps referred to above for keeping Skype active, or some general Android setting.

Non-rooted, Android 5.1.1, Skype, Sony Z3 compact. I'd prefer not to root but this issue is very important to me and if that's the only option I'd accept an answer that involves rooting the phone.

I'd prefer not to install a custom mod, but I'd consider it if that can somehow reliably fix this problem and give me reliable notifications and incoming calls any time I'm online and someone calls or messages me by Skype.

  • Do you use Stamina mode on your phone? This may be the cause of your problem as it can limit the amount of apps open meaning that skype can get end once you start doing other stuff on your phone?
    – Matt07211
    Mar 23, 2016 at 22:32
  • No, I checked that, I both made Skype an exception to stamina mode and turned it off 95% of the time, made no difference Mar 23, 2016 at 23:09
  • Okay it was worth asking, I curently don't know anything else as I don't use the phone or app
    – Matt07211
    Mar 23, 2016 at 23:19

2 Answers 2


Your search it appears is for a solution that keeps Skype active only when you are on line . Since you couldn't find an app or root unless necessary , I am suggesting you to look at automation as an alternative

There are plenty of them, but I use MacroDroid, since it is easy to learn and the behaviour can be easily customized to get the result you want. Besides,free version allows you to create upto 5 macros and for the task at hand, free version suffices. I prefer automation as a first choice, when I need to get something running the way I like and not depend on apps.

The macro would look like this and needs to be tested. I gave up on using Skype, so can't test it, but in principle should run fine


Regular Interval (can be configured in seconds,minutes, hours as you require - the macro runs periodically based on this setting)


Launch Skype> force new with the constraint WiFi connected to any network

(You want Skype to be launched at the periodicity specificied in trigger, only when you are connected on Wifi. Assuming WiFi to be your mode of being on line)

Launch homescreen ( you don't want to see Skype launching when you are say mailing for example, so you get to the home screen for you to pick up the mail app and resume)


Application running> not in foreground>Skype

( macro runs only when constraint is TRUE. Here, you are ensuring that macro isn't triggered when you are actually using Skype !!!. You can add more constraints like the time period you want the macro active, day of week etc. These can be added with AND (or) OR logical operator. Bottom line is macro runs when constraint(s) evaluate to a logical TRUE).

You would need to test and fine tune on how frequently you want this macro to run.

All the best....

  • Sounds really promising, exactly the kind of trick I was looking for. I can't test it for a few days, will come back as soon as able Nov 14, 2015 at 11:33
  • 1
    I've been trying a whole bunch of different macro configurations, and unfortunately I haven't yet found one which solves the problem. I have, however, been able to prod Skype into giving me more accurate information in the status icon that sits in the notification bar - it pretends to be active when its not less than it used to, which is small progress. I suspect that something else is going on. +1 for the tip, and I'll keep trying Nov 24, 2015 at 13:06
  • 1
    A couple of things. Download "quick shortcut maker" and see if you can get more insight into Skype and if you can trigger them to keep it awake. Same with "secure settings" , an extension that is more powerful . My knowledge on this rudimentary . Both are on play store. Parallely , access macrodroid forum from within the main page of app and post your problem there. Lot of experienced guys who can guide you better than me plus mail developer posting link of this and with your sys logs accessible from main page of app. My time does not permit research. post progress pl
    – beeshyams
    Nov 24, 2015 at 14:14
  • 1
    Please see sys settings in this answer of mine. This could be messing your test android.stackexchange.com/questions/128588/…
    – beeshyams
    Nov 24, 2015 at 14:32
  • 1
    Nice, thanks, I'll try those system settings, I suspect MacroDroid might be being restricted somehow when the device is locked (or, Skype is limiting itself, which would be harder to solve). I'll try those later Nov 24, 2015 at 14:36

I had the same problem. If Skype is running, either active or in the background, it does ring OK. But if it is off, doesn't ring. Fixed it by going into settings, notification settings, Skype status. When you switch this ON, Skype is always running in background I guess. Takes a bit longer to start ringing but it does (at least for me).

Stock android 5.1 on Moto G. Latest Skype app as of June 2016.

  • 1
    Unfortunately I'd tried this already, doesn't help. Calls are ignored even when Skype status shows as active. Aug 2, 2016 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .