My Galaxy 5 has this problem for some months now: wifi stops working, I try to enable it and the phone says "Error" without any other further information. The only way to make it work again is rebooting the phone. I think this problem has been related here before.

But I managed to save the system log and got the following:

08/04/2011 23:01:50 [ERROR] WifiService(166) setWifiEnabledDialog: true
08/04/2011 23:01:50 [ERROR] WifiService(166) ****************setWifiEnabledDialog(), allowWifi****************true
08/04/2011 23:01:50 [INFORMATION] WifiService(166) setShowAccessPointListDialog():true
08/04/2011 23:01:50 [INFORMATION] WifiService(166) setWifiEnabledDialog(): true
08/04/2011 23:01:50 [INFORMATION] wlan_tool(11010) wifi loading 
08/04/2011 23:01:51 [INFORMATION] wlan_tool(11014) Driver is initialized. load it 
08/04/2011 23:01:51 [INFORMATION] wlan_tool(11021) ar6000 driver fails to load 
08/04/2011 23:01:51 [INFORMATION] wlan_tool(11029) wifi unloading 

I'm trying to understand what's going on here. What exactly is ar6000? Maybe the network interface? How can I get more information about the error itself?

I have already uninstalled almost any app that could change the wifi behavior, and the problem persists. Juice Defender is still installed, but the problem already existed before I first installed it.

  • 1
    ar6000 is the driver for the Atheros 6k Wifi chipset. From browsing on XDA, it seems to be a common issue with Galaxy, not sure if there is any fix yet, though many reported that reboots works.
    – Lie Ryan
    Sep 11, 2011 at 0:18
  • Yeah, I've noticed this is a pretty common problem unfortunately. I had the hope that bringing this log would help to understand the causes, but up to now it's being useless. Thanks for the link about the driver. Sep 12, 2011 at 16:06

4 Answers 4


I've seen a number of people report that the WLAN test dialer code will allow the driver to reload properly (example). I believe it's *#*#526#*#* on many Samsung phones, but this post indicates that it may also be *#*#528#*#* or *#*#232339#*#*. This may not work on all devices, since manufacturers tend to include/remove different dialer codes almost at a whim.

If you're unfamiliar with dialer codes, simply open your dial pad and enter the sequence as though you were attempting to dial the number *#*#526#*#*. Your phone should then jump to the WLAN test facility.

  • great! it worked. :-) finally a better solution than restarting the phone. Dec 25, 2011 at 23:57
  • All three of these codes bring up the correct interface on my GT-5570, which manages to successfully load the drive; unfortunately it then fails to find any networks when it scans.
    – Jules
    May 8, 2012 at 11:32

Something that's helped me with similar Wi-Fi errors on my Vibrant is the Blade Wi-Fi Fix. You might give it a shot and see if it works for you.

  • Unfortunately did not solve the problem. Dec 17, 2011 at 12:11

One thing I've tried on several models of Galaxy's is to do a Factory Reset in the "Settings" menu. For some reason the WiFi drivers get corrupt and a reset fixes this every time.



wifi driver issue, factory reset or firmware upgrade could help you.

  • Answers that provide no information except a link to somewhere else are not answers at all. What happens when that link stops working, for instance?
    – ale
    Dec 2, 2011 at 14:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .