3

Using Android 6. Auto correct usually works very well, so I don't want to turn it off. However on some occasions it stubbornly 'corrects' some words which I don't want, which is extremely inconvenient.

These words are not in my personal dictionary. I've tried the following:

  • add the word I want to my personal dictionary
  • add the word I want to the 'all languages' dictionary
  • add the wrong word (to which it tends to autocorrect) to the custom dictionary and then remove that
  • repeatedly type in the word and when it autocorrects, click it and set it back to what it was, hoping that Android will learn my preference (I really tried this many many interations)

It's driving me nuts. How do I force Android NOT to autocorrect certain words? Or rather, how do delete some words from its own dictionary?

P.S. I know several similar questions like these were posted before, but they were all either outdated (apparently referring to much older Android versions) or the posted answers didn't work (I've tried them all). Quite some references to Android in 2011 are no longer relevant.

P.P.S. I'm using a Nexus 5, default built-in keyboard.

6
  • Keyboards tend to be brand-specific. Can you tell the brand and model of your device?
    – SarpSTA
    Nov 15 '15 at 1:56
  • Right, I added the Nexus 5 spec (that's from LG) so I'm using just plain stock Android 6.
    – RocketNuts
    Nov 15 '15 at 9:39
  • Could you possibly give an example of a word you're trying to type, and the word it autocorrects to? Nov 15 '15 at 16:37
  • @DanHenderson in Dutch for example, when I type daf, it autocorrects to DAF, which I never want (it could autocorrect to dag or dat which are legit words, but I never want DAF).
    – RocketNuts
    Nov 15 '15 at 23:30
  • Similar problem here. I have Vanilla Android UI on my Moto G3, I'm using default keyboard (which is Google keyboard). When I type hi, it auto corrects to Hi. Super annoying. Jan 18 '16 at 2:19
0

I think it might work to misspell it and then not press spacebar. When the suggestion pops up (on my Gboard, there are always corrections at the top of the keyboard) you can see the word you do not want it to change to if you were to press spacebar. You then long-press that suggestion and then it gives you an option to remove that suggestion. I just did it, and it seems to work so far. I have tried to misspell the word I am having a problem with in all possible ways, and so far it has worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.