Having read several threads, let me endeavour to outline the problem.

My computer: laptop running Win 7-64 bit
Tablet: Nexus 7 with latest update (which seems to have caused the problem)

Attempted solutions:
Uninstall the driver
* done this twice
* there are five driver files
* WpdMtpDr.dll (c:\windows\system32\drivers\umdf)
* winsub.sys (c:\windows\system32\drivers)
* wudfrd.sys (c:\windows\system32\drivers)
* WpdMtp.dll (c:\windows\system32)
* WpdMtpUS.dll (c:\windows\system32)
* attempting to delete the file winsub.sys results in a message saying permission is required from TrustedInstaller. I don't know what that is, nor how to get permission. So, while I have been able to uninstall the driver, I have not been able to delete it.

NOTE: wpdusb.sys is designated as obsolete by Microsoft

Restart the devices
* first thing tried - to no avail

Use different cables
* done - no effect

Connect through different USB ports
* done - no effect

Change the Storage and USB settings on the tablet
* accessing the menu in the upper right corner only gives "Help and Feedback" as an option. There's nothing about MTP (whatever that is)

Yell, scream and swear
* done - gave me a headache

The device worked properly before the last system update for the Nexus tablet. The device now connects to the PC, and is recognised as being connected. It simply does not display any files.

I am an author and use my tablet extensively for writing. It is important for me to be able to connect the tablet to the computer and move files between the two. Please do not suggest work-around solutions such as Drive or Dropbox. I prefer to have devices that work properly.

Thank you for taking time to read this through and consider the problem. Please let me know if there is additional information that would be useful. Also, please be aware that I am not a developer and do not understand the jargon or shortcuts used by developers. Please be explicit when suggesting a resolution.

  • It was answered by @John W and edited by Andrew. You can consider "accepting" the answer to signify that the solution solved your problem. This can be done by ticking the mark, next to answer – beeshyams Dec 23 '15 at 16:32

Connect your Nexus 7 to the PC, then on the android screen swipe down the icons from the top left side of the screen. One of the boxes shown will say "USB for Charging". Tap that box and select "Transfer files (MTP)". Now your Nexus files will show up on the PC as they used to do before the upgrade.

BTW, you have to do this every time you connect to the PC.

  • Greetings Andrew, Thank you. Yes, this fixed the issue. It is surprising that it would have to be done every time the tablet is connected to the PC. I have owned the tablet for several months, have connected it to the computer repeatedly to transfer manuscript files, and have not had to do this before. Ah well, the one surety in life is that things change. If the issue arises again, I now have the answer. Thank you. – Conrad Hall Nov 24 '15 at 4:56

protected by Community Apr 9 '16 at 17:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.