2

TL;DR

My Rear Camera doesn't work and the Firmware version for it is null and I think I need to install it manually. How do I do that in a Samsung Galaxy S4 GT-I9515L with PDA I9515LUBU1BOJ1 and CSC I9515LZTM1BOI1?


Everytime I open my camera app, I get a black screen and some of those times it shows a Updating Camera Firmware. Please Wait...

When researching the web, I found the *#0*# code that tells me Data Line Fail and Camera Failed when I hit the Mega Cam buttom.

Also, the *#34971539# code shows me that I have no firmware installed:

Rear Camera (Main)
Cam FW Ver: null
Phone FW Ver: S13F0LAGE10

What I tried:

  • Factory Reset. After this, the Google Account got in and re-installed every app and restored every data, but I didn't consider this being the problem due to the Cam FW Ver: null appearing to state that I have no Camera Firmware currently installed.
  • Phone Firmware Update. I found a Firmware on SamMobiles that matches my Country and Carrier dated 2 weeks ago for Android 5.0.1. I know I hadn't gotten this from OTA because although I use TIM carrier, my phone had the Claro carrier logo, so technically my provider and the firmware didn't match each other. I successfully installed the 5.0.1 firmware and the phone works perfectly, except the camera problem that still persists (no Firmware version).

My guess is that I have to install the camera firmware manually, but I have no idea how to do it. I'd love if somebody could point me to the direction in which I can find the solution.

When opening the app, it gives some freezes, but it's possible to hit the switch camera and use the front camera regularly.

Thank you very much.

  • Have you tried updating the camera firmware from that *#34971539# menue? use the second option which you can see here – benjamin Nov 16 '15 at 14:41
  • @benjaminS in my case, it's the 3rd button and it's disabled along with almost all buttons in that menu. – Marco Aurélio Deleu Nov 16 '15 at 14:42
  • when did this problem occur? have you had any damaged hardware or replaced something on your device? seems really weird to me – benjamin Nov 16 '15 at 14:50
  • @benjaminS I believe before I installed the 5.0.1 firmware, all those buttons were enabled (which was yesterday), but I didn't pay attention to any of them and I thought that updating the phone firmware could solve it all. But the actual problem in the camera has been happening for about 1 month now, I just was too busy with other stuffs to set aside some time to play with it and see if I can get a fix. My biggest problem now is that I can't access Web Whatsapp because the QR Code uses the camera and the camera seems to be uninstalled (no firmware). – Marco Aurélio Deleu Nov 16 '15 at 14:52
  • Maybe this thread can give some pointers? – beeshyams Nov 16 '15 at 15:03
1

Unfortunately, I could not find a software solution, so I took it to the warranty and they fixed it by replacing the camera.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.