Folks, I unlocked the bootloader and rooted my XPeria L without problems, I then installed TWRP, made a complete backup and tried flashing the Ressurrection Remix ROM. But the phone doesn't boot up and the ROM installed the Cyanogen Recovery atop my TWRP, and now I can't find a way to restore my backup.

I tried flashing the system image again through Flashtool, but it doesn't work. Flashtool returns an error saying "Error Flashing. Aborted".

I then tried to reinstall twrp by connecting the device in fastboot mode to my PC and issuing the command:

fastboot flash recovery recovery.img

But it returns an error message saying "FAILED (remote: Command not allowed).

What can I do to save my device?

  • Run fastboot flash boot recovery.img and fastboot reboot It'll let you to custom recovery once, there you can try Factory reset, Wipe Cache, Dalvik Cache and check if the device boots without any issue.
    – Manu
    Commented Nov 17, 2015 at 1:53

1 Answer 1


I found out a way to do it. As pointed in the comments, I had to flash a new boot image, because for some reason on sony devices (not sure if on all of them) you can't flash a new recovery through fastboot.

So what I did was search for a new XPeria L boot image with twrp, which I found here:


I flashed it through fastboot and booted back to recovery, and then proceeded to restore the backup I made before trying to flash a custom rom. From there I flashed a new rom and now everything is working fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .