4

From many days I am getting unwanted ads and notifications. I uninstalled many app, and also did a factory reset also, After searching, I found Alarm Controller may be the culprit. As I lock my screen and the then try to unlock it again, the on-screen ads blinks all the time. I had a screenshot of the app

Alarm controller running

Please help me to get rid of these ads. Let me know if any more information needed.

  • 1
    It's a known malware. First thing first, can you uninstall it? Are you rooted? Seems it's installed as home launcher, can you change it to other launcher? – Andrew T. Nov 17 '15 at 5:38
  • No i cant uninstall it. also it automatically install hola launcher. so i can change my launcher to hola launcer – RahulAN Nov 17 '15 at 7:19
  • Is there any message when you failed to uninstall it? Also, when you change to Hola Launcher, does the ads appear again? (I know it's not the perfect solution, but if it can work as workaround for now..)..... so, try turning off the Accessibility setting for Alarm Controller. Also, look at Security - Device Administrators and disable it (if exists). Then try to uninstall it again. – Andrew T. Nov 17 '15 at 7:24
  • I think recent versions of android has capability to turn off notifications for particular apps. – Santosh Kumar Nov 17 '15 at 12:02
  • No it simply says uninstall unsuccessfull, No Still i get the ads either i switch to hola launcher, I am always turning off the accessibility but as i lock and unlock the phone it again turn on automatically. – RahulAN Nov 18 '15 at 3:51
1

At last I got a solution or workaround, I installed NoRoot Data Firewall and then created a VPN on my own mobile and now I am having full authority to whom to give access to network and whom to not.

This is just the workaround I found, it doesn't remove the Malware. But it worked and get me out of the frustration.

0

Use firewall to restrict the network. Try this:

  1. Install firewall app (e.g. CM Data Manager - Speed Test)
  2. Open the app, go to Network Firewall setting. You will see all the apps are unrestricted
  3. Set Alarm Controller to restricted app: tap ON to restrict the app. It will stop the unwanted notification & ads in your phone.
  • I will try it today – RahulAN Nov 19 '15 at 8:51
  • I Tried this solution but it Creates a firewall with 2g network and not with wifi . So it didn't worked for me. Noroot firewall worked for me. – RahulAN Nov 24 '15 at 4:03
0

I have a similar situation ..I have tried all the stuffs suggested here.. 1) Using CM Data Manager - Speed Test - It does not work. It only allows to Create restriction at firewall with 2g network and not with wifi. 2) Turning Off the Accessibility option in Settings for Alarm Controller - is again temporary solution as the it gets turned "ON" by itself with few minutes.. Malware is doing it i guess. In the meantime the malware is getting strong. Now the alarm controller is no more version 2.0 like before and has updated itself to 4.0 (i hv no idea when and how) . Apart from installing several random apps (hola launcher quite repeatedly) by itself now this malware is creating some shortcuts with porno icons which on clicking takes you to some linkup websites and/or result in some downloads.. its getting really frustrating.

  • 1
    have you tried the workaround i followed? (In upper comment) – RahulAN Nov 27 '15 at 8:44
  • No i havent.. I need to try it.. BTW Did u say, u tried Factory Reset without restore (google apps ) option yourself and still face the issue.. Another thing, I got update for Android marshmallow 6.0 but am unable to install.. During installtion it erros out.. Did you (or anyone else) face this issue. Please confirm – Vick Dec 24 '15 at 19:50
-1

Just click stop button and power on/off your phone to reset from scratch. Click Settings and you will get various options to deal with. It's very simple and you won't get such ads, all the best !!

IF NOT, than you should go for Factory Re-set of this phone, thanks.

  • 1
    I tried all the things.. but no luck – RahulAN Nov 17 '15 at 7:20
-1
  • Turn Off the Accessibility option in Settings
  • Settings → Applications → Alarm Controller → Clear data & Clear cache → Disable and Force Stop. I tried it and it works for me.

protected by Community Nov 22 '15 at 18:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.