It reboot smoothly. It started already doing the setup. But if you click NEXT there is box popping out, showing this stuffs:

  • Unfortunately, Samsung account has stopped
  • Unfortunately, Google account Manager has stopped

So, I cannot continue doing the setup. Because, even you click the OK button and click again the NEXT buttom it come back again.

What happen to my samsung galaxy S3? Can you please help me?

6 Answers 6


I had the same problem recently. The phone was constantly reporting Google Play Services and many others as having stopped. A hard-reset left me unable to complete the initial setup, as the account manager kept stopping too. My S3 was stock standard, not rooted or running any custom firmware. I was able to fix the problem, and I'd like to share my solution.

  1. Download Samsung's "Kies" software. Searching the samsung.com site pointed me to Version 2, but once installed the software self-updated to Version 3.1. A restart was required after installing (I'm on Mac, but I understand with will work on Windows too).

  2. Power on the phone. Start Samsung Kies software. Without touching the screen, I connected the USB cable to my computer.

  3. Tools > Firmware upgrade and initialisation I was warned that the current firmware was already installed, but chose to proceed anyway. The current firmware was downloaded and installed on the phone, which took around 20 minutes.

After restarting the phone, I was able to complete the setup process without any errors. The OS now appears to be working correctly (Android KitKat 4.4.4). If I had to guess, I'd suggest it was some older versions of my network's own customisation that was incompatible with recent Play Store Services updates. Interestingly, my phone now has less added software (only 2 extra apps I can see) and seems to run better than it did originally.

I hope this info helps others too.

  • 1
    just out of interest, this only worked for me when I did the firmware upgrade on a mac, it did not allow me to make the update on my windows machine. Commented Jul 18, 2016 at 1:46

If you want you can bypass setup. Tap to top left, top right, bottom right and bottom left respectively (clockwise) at the screen that shows up once you boot up the phone. It might be hard to find the initial spots at the first try (I know from personal experience) so try a few times if it doesn't work at first try. Here's a how-to video for additional help!


Easy to fix:

  1. Go to Applications Manager.
  2. Go to SD CARD (top right).
  3. Go to RUNNING (top right).
  4. In the list, find "Samsung Link".
  5. Terminate it (Clear Data, Clear Cache, Force Stop, Disable). --- Sorted ;-)

Did you ever get a fix for this? Im having the same issue with my S3. Nothing mentioned in this thread so far has worked.

EDIT: got it to work with Keis. Had a faulty cord.


I tried clearing cache and doing a factory reset from recovery mode and it didn't work. I have now fixed the issue. Install Samsung Kies on your computer, plug in your phone and select Tools/ Firmware Upgrade Initialisation and update from the menu. It will completely reinstall the latest android update and I haven't had any issues since with Google or Samsung apps crashing.


If you are using a custom recovery, clear cache and Dalvik cache.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .