4

We have a Samsung GT i5800 with Android 2.1update1.

When I put a memory card in it, it recognizes it, great!

But: When I want to connect the phone via USB to my PC: this picture DOESN'T comes up:

enter image description here

And I can't see my memory card through my phone from my PC!

On other phones, the memory card is OK. (tried another android phone).

The USB cable is good, tried it with another phone.

What could be the problem? Are there any settings that I missed?

1

You should check your USB connection mode. This can be found in Settings -> Wireless and network -> USB Settings. This should be set to Mass storage to access the memory card. Alternatively, you can use the debugging mode by selecting Settings -> Applications -> Development -> USB debugging. After this plug your phone in to the USB, open the notification bar and tap the USB debugging notification to get to mount your drives.

  • I can't find this in the menu: "Settings -> Wireless and network -> USB Settings". And no matter if I turn OFF or ON the USB debugging, it still doesn't pop's up, to mount :\ – LanceBaynes Aug 31 '11 at 11:00
  • Do you get the USB Debugging icon in the notification bar when you plug the phone in with debugging enabled? – onik Aug 31 '11 at 13:29
  • after RESETING the phone to default settings, turning on the usb debbuging worked!! :) – LanceBaynes Sep 2 '11 at 8:27
2

Check Settings -> Applications -> USB Settings or Settings -> About Phone -> USB Settings, rather than the network settings.

I would also try a different USB cable, just to make sure, as well as a different USB port and a different computer if you can. You can try wiggling the connector in the device as well and see if it makes proper contact intermittently.

As Al notes here this sort of problem seems to come up pretty often with Sasmsung phones, so you might just be out of luck. If all else fails, though, I would try a factory reset.

  • 1
    Cable change worked for me. – Amin Ariana Mar 21 '16 at 16:09
1

I had the same issue with 2 Galaxy Mini. No matter what I tried, the USB notification did not appear when connecting the USB cable to 3 different ports in 2 PCs.

Solution:

  1. Settings -> Applications -> Development -> USB debugging: enable
  2. Changed the USB cable; maybe it had good fabric, but it was faulty.

With a new cable and the point 1., the USB notification now appears like a charm, as usual.

For me, SOLVED.

HTH

  • 1
    Wow, cable change worked for me! (My old cable worked for my computer. My coworker's cable worked for his. But my cable didn't work for his computer. Boggles the mind.) – Amin Ariana Mar 21 '16 at 16:09
0

HTC Incredible 2 (Android 2.3.3):

Settings -> Connect to PC -> Default connection type.

Where you can choose from

  • Charge only
  • HTC Sync
  • Disk drive
  • Mobile Broadband Connect
  • Media sync
  • Internet pass-through

Settings -> Connect to PC

Also has an option

Ask me
Ask me about USB connection type whenever I connect my phone to a PC

When connected to a PC there is also a message in the notification area, that provides quick access to the Connection type settings.

0

This might happen if you have faulty USB cable, try using a different cable.

Sometimes the cable might appear to work because the "charging" lightning icon will appear at top, however it will work only for charging and won't work for data transfer.

0

Changing the USB cable did it for me. I had forgotten that there are two types of USB cables:

  1. charging only, no data lines
  2. charging AND data, has additional wires

If you are using the charging only cable, you will never see the USB notification.

-1

Go to Settings → Storage and you will see a USB symbol. Tap it → select Media and now you will be able to transfer file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.