1

I'm using a Trio Stealth Gen 5 on 4.5

I think with some crashed reboots I may have messed up my filesystem. I've never used Linux prior to this, but some Google searching lead me to a few things. I have root, ROM Toolbox (and busybox itself)

I don't have access to a comp with Admin priv, so I can't install ADB drivers. Nor do the comps have the ability to boot from disk (and run a portable Boot Disk)

I noticed the problem when one day, as I was attempting to transfer files over Media Device protocol (MTP only gives DCIM folder :| ) when partway through, the transfer froze up.

I had to leave so I didn't have time to diagnose it.

My Trio has no functionality to change default install location to SD card, So to transfer a backed up 1.09 GB obb file for a game, I had to put it in root/data/media/obb/com.whatever (easy to figure out despite how very very new I am to superuser and Linux)

Half way through the transfer, it froze up. I tried doing

su
touch /forcefsck

But nothing popped up during boot, and boot took as long as normal.

When I tried doing

reboot -rF now

It said there wasn't a reboot command. There also wasn't a chd apparently.

In system/bin there's no fsck, but there is fsck_msdos, e2fsck, an the fsck for ExFAT.

What should I do to fix it?

  • 1
    e2fsck should be the binary to check your ext4 file system (default on Android devices unless it is fully encrypted). reboot does not exist, use shutdown -r instead. – GiantTree Nov 21 '15 at 18:49
  • 1
    What is chd? I can't find it in primary Google searches. Also, are you certain you've installed busybox's applets? Installing the busybox app doesn't help in anything. You have to open it and install the binaries for various tools. In order to access what busybox offers, execute busybox command. It will show list of all the installed applets. Anyhow, which Android are you using? In all of my devices, reboot is under /system/bin/ and it works, haven't tested those arguments though. – Firelord Nov 21 '15 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.