4

Even though the title enunciates the problem, the question is about a solution or workaround to this behaviour.

As I have found, Marshmallow normally colors the status bar icons (Wi-Fi, Battery, Clock) on the launcher (home screens) by taking the colour of the topmost region of the wallpaper currently set and tinting the icons to a darker version of it.

This is all well and good if you have the sky there in your wallpaper, or something light-coloured; but if you have a night-time cityscape as your wallpaper, it colours the icons to be "Darker Than Black" (pun intended). So, magically, your Wi-Fi, Battery, Clock and everything else just disappears from the status bar. Only they haven't disappeared. Set a light wallpaper or a dark one with the top region light, and they're back.

I don't think that this is a problem with the launcher, as I use both Nova Prime and Google Now Launcher, and both have this problem. I also checked the System UI Tuner options for such settings relating to this tinting mechanism, and they're nonexistent (The settings there include what statusbar icons and quick settings tiles to show, battery icon customization, demo mode, and that's it).

I know of 3 possible workarounds to prevent this behaviour:

  1. Disable Nova Launcher's transparent statusbar option under "Look and Feel", but I don't want to do that.

  2. Use Xposed+FSCB (Flat Style Colored Bars) or similar. Well, Xposed on Lollipop 32-bit was unstable. Marshmallow ARM64? (I really have no idea, but I'm definitely not willing to take the risk.

  3. This was a no-brainer. Use a light wallpaper. (Well, then I wouldn't have asked this question, would I?)

The question is: "Can I have the best of both worlds (i.e., my dark nighttime cityscapes as wallpapers and visible statusbar icons)?"

The solutions I'll prefer can involve root but not Xposed, and not 1 or 3 above. Also, it's preferable if the solution tints the icons to white on a dark wallpaper but preserves the stock behaviour otherwise, and doesn't affect apps other than the launcher, because my problem doesn't affect apps other than the launcher.

Background:

My HTC Nexus 9 16GB, Wi-Fi, flounder/volantis running Marshmallow 6.0.0 MRA58K rooted with TWRP 2.8.7.0 ElementalX 4.02

Some pictures:

Click images to enlarge

Light wallpaper:

IMG

Dark wallpaper:

IMG

Dark wallpaper with light top region (Whaat?):

IMG

What I want ( This is from my phone, same Nova Prime, 4.4.2, (Lollipop signal icons courtesy GravityBox KK)):

IMG

  • @AndrewT. I don't know why it was happening in Google Now Launcher, but turning off said feature in Nova fixed the issue in both launchers – Tamoghna Chowdhury Nov 22 '15 at 8:31
  • I had no idea Nova enabled this by default on Marshmallow. The option doesn't seem to exist on my 4.4.2 phone – Tamoghna Chowdhury Nov 22 '15 at 8:33
  • Yeah, that problem might be on my side, but as it got solved, I won't investigate it further. Thanks. – Tamoghna Chowdhury Nov 22 '15 at 8:44
6

Based on reddit (and I have tested it myself), apparently it's a feature of Nova Launcher on Android 6.0 Marshmallow called "Dark icons". It seems it's enabled by default for existing users after updating the app (on my case, new installation will have to turn this setting on manually).

The setting can be checked on Nova Settings - Look & feel - Dark icons. Note that this is a new feature of Marshmallow, allowing an app to have black status icons for light status bar, and thus, the setting is only available on Marshmallow and above.

As for why it also affected Google Now Launcher, I actually have no idea, since I couldn't reproduce the issue on Nexus 5 running Marshmallow 6.0. Even if I leave the option enabled on Nova Launcher, changing the home setting (on Settings - Home - Google Now Launcher) and pressing "Home" button will revert the whole launcher to Google Now Launcher with its default white icon.

  • You're right. I got it by default by updating the app. – Tamoghna Chowdhury Nov 22 '15 at 9:14
  • I can't believe that I've just changed ROMs and had the same issue and couldn't work it out until I switched back to the stock launcher and found i could see the icons. Then I realized it was Nova launcher causing the issue. Thanks I've now solved the problem. – user181579 Aug 7 '16 at 11:27
1

Based on @Andrew T.'s research, I understood that this isn't actually an issue with the system, rather it was a feature, "Dark Icons", that Nova Launcher only shows on and enables by default on Marshmallow, not on KitKat or lower (unsure about Lollipop).

The option on Marshmallow devices exists under Nova Settings → Look and Feel → Dark Icons (a switch). Disabling this made the icons go white everywhere, as normal.

I had no idea why this affected Google Now Launcher also, but disabling the option in Nova fixed it there too. The effect on Google Now Launcher made me think it was a system feature/bug, but I'll clarify this was not actually so. This was due to Nova Launcher and some unknown condition which made it affect both launchers. That reason might be system-specific. Thanks for everyone's help.

protected by Community Apr 12 at 20:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.