Recently my Colorfly E708 Q2 tablet stopped working. First time this happened a message box popped up, with the text "Unfortunately System UI has stopped" or something like that, but i wasn't able to close the pop-up box, because the system didn't respond to any user interaction. So i decided to restart the tablet.

Display doesn't work, doesn't respond to touch, nor to mouse when connected through usb. I need to mention, that when the mouse is connected, the mouse cursor shows up on the screen, and does even track the movements of the mouse, but as i said, it does not respond to clicks.

I've seen on some forums, that the only thing that would help to fix the tablet would be if i'd replace the firmware. Sadly, since the developer options aren't enabled on the tablet, i was not able to reboot into a boot menu. The device has no physical sound buttons (only power, home and reset) , so what would work with other devices, doesn't work in my case.

Is there any way to fix the system ui, or re-flash it in any way? I mean it was cheap, but it worked for me so I don't really want to buy a new one.

I plugged in an USB keyboard, but the only thing I could achieve was to adjust the volume of the device.
+ A new box popped up, with the message "Launcher stopped working", with two actions: wait and close. Of course its not possible to select either.

Tech Specs
User Manual

  • Max, just to confirm: have you attempted to use Power and Home button in combination when phone is powered off?
    – Firelord
    Commented Nov 23, 2015 at 6:18
  • 1
    @Firelord i did. i tried but until i don't release one or the other, the tablet wont start. it just hangs there with a black screen. I have tried all the 6 possible combinations with the buttons, and then some patterns. Non worked so far
    – therufa
    Commented Nov 23, 2015 at 9:54
  • 1
    Max, I don't have a tablet or the Android KitKat but in Lollipop I am perfectly able to enable debugging mode using physical keyboard only. Are you claiming that navigation keys (left,right,up,down) combined with Tab key are not working? I used them to navigate. I'm also able to navigate system using num keys, mainly 2,4,8,6,5 (num lock off).
    – Firelord
    Commented Dec 3, 2015 at 5:48
  • @Firelord The problem is, that the whole launcher screen is not responding. After I start the tablet, I'm able to do some general things, but i can't get the launcher to respond. The software keys aren't responding either, so the only thing i'm able to do is adjust the sound/brightness and move the mouse when plugged in.
    – therufa
    Commented Dec 3, 2015 at 16:42
  • the tablet doesn't factory reset when pressed the reset button ? usually reset button need some sort of pin (needle - don't know what they are called ) Commented Dec 8, 2015 at 10:40

1 Answer 1



To fix this problem, first shut down your tablet. Boot into the bootloader by booting up regularly, but holding down your power and volume up buttons when you see the logo. If you haven't installed fastboot, do that first.Then, go to the command line and type in

fastboot oem unlock

Then, find and download a factory image, then run

fastboot flash /path/to/factory/image.zip

fastboot oem lock

fastboot reboot

Hope this helps!

  • I agree with attempting a factory reset, but what you are suggesting will also void the device warranty, and that needs to be clear. In addition, the question states that the user cannot navigate to the debugging options, which makes it impossible to install fastboot.
    – Ethan Z
    Commented Dec 7, 2015 at 2:44
  • 3
    Your answer doesn't help. OP mentioned: "The device has no physical sound buttons (only power, home and reset) , so what would work with other devices, doesn't work in my case.". OP wants to either re-flash the system or enable USB debugging somehow. OP cannot achieve latter because system is not receiving touch input and cannot go for former because traditional methods of booting into recovery or bootloader doesn't apply on his tablet. Also, how are you so certain that fastboot flashing would work on his tablet? Please explain.
    – Firelord
    Commented Dec 7, 2015 at 9:18
  • On page 6 of your user manual, the manufacturer suggests a reset by performing the following: When the tablet cannot be turned on or does not respond, use a pen or another tool to poke the Resetbutton (next to the home button) and then press the Power button. Have you tried this? Commented Dec 8, 2015 at 14:26
  • I did. nothing changed
    – therufa
    Commented Dec 8, 2015 at 17:36
  • Actually, Ethan Z, fastboot does not require usb debugging, only adb
    – Ethan Tang
    Commented Dec 11, 2015 at 4:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .