2

After every reboot Android keeps loosing Launch Defaults, some app settings and even some of installed updates and installed apps.

I re-flashed the stock firmware, then applied all the OTA updates. After that I only flashed TWRP, GApps (Pico Uni) and SuperSU.

Given this, I tried several Factory Resets (from Settings), but every time, after installing some number of apps, some of the above start disappearing with every reboot. As I varied the sequence of apps installed, the data lost is every time something else. Examples from different Factory Resets include:

  • lost default app for search on Home button tap-and-drag
  • lost default app for browser
  • lost Gmail preferences (Global ones) and/or account Sync flag
  • updates of Motorola Camera and Motorola Gallery (via Play Store)
  • some of apps I just installed (via Play Store) disappear after reboot
  • internal storage becomes read-only for apps (even rooted ones), but remains writable for Android File Transfer

What I tried so far:

  • erasing cache and dalvik cache--actually after nearly every app installed, and of course after Factory Reset
  • uninstalling and reinstalling every app in question
  • manual resetting app defaults in Settings>Apps, both globally and for individual apps
  • none of the apps installed to SD / internal storage, so it shouldn't be an issue

What I didn't try include:

  • erasing internal storage and SD card (most apps were previously "moved to SD")
  • whatever reformatting or repartitioning the Android partitions

Any ideas what to try next?

I have Moto G 2nd gen (XT1079 dual-SIM). It runs Android auto-updated from stock 5.0.2 22.36.1 (build LXB22.99-7.1) to stock Lollipop 5.0.2 22.46.7 (build LXB22.99-24.7).

0

The root cause was a wrong edition of TWRP: I mistakenly downloaded TWRP for Titan series of Moto G 2, while my XT1079 phone is obviously part of Thea series.

Discovered that through trial-and-error in several other re-installs of the original ROM, GApps, TWRP and OTAs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.