2

I am getting way to many calls from marketers these days. I have listed my number on no call list and they still keep calling. Most of the time I can't be bothered to report everyone.

How to block callers from private numbers that are hiding their Id?

5

On Android version 5.1.1 (Samsung Galaxy S6 Edge)
One way to do it is go to Phone (like you would make a call) then click on the More in top right of the screen and choose Settings then Call Settings > Call rejection > Auto reject list and select the "Unknown" option.

enter image description here

Hope this saves you some time.

  • 3
    It's probably worth editing your answer to add your device details as these options may not available on all devices (e.g. it's not available on my Nexus 6P). – bmdixon Nov 23 '15 at 17:24
  • @bmdixon I have added Andriod version do you think phone model is relevant too? – Matas Vaitkevicius Nov 23 '15 at 18:37
  • Yes, I've used Nexus devices for years and none of them have had this so worth adding your phone make and model. If it apples to other devices then people can comment/edit to add other info. – bmdixon Nov 23 '15 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.