1

After installing Cyanogenmod 12.1 on my LG G2 (d800) I'm unable to boot into custom recovery.

  • If I use Cyanogen to boot into recovery, my phone just turns off and I can't turn it on for several minutes.
  • I tried to get TWRP by downloading their image and installing it through the ADB command on their website (installing it through FreeGee results in an error). If I then boot into recovery, I see a black screen with the text

    [810] Fastboot mode started [910] -- reset -- [920] -- portchange -- [1460] -- reset -- [1470] -- portchange -- [1800] fastboot: processing commands

and nothing happens.

Is there a way to resolve this without reinstalling Cyanogenmod and/or going back to stock firmware?

  • how did u install recovery and how are you accessing it ? via adb command or via key combination ? – lord-ralf-adolf Nov 24 '15 at 1:27
  • To install TWRP I followed those instructions: twrp.me/devices/lgg2.html To boot into recovery I press Recovery from the reboot menu or use Quick Boot. If I boot by holding volume down + power when the turn is off I get into Factory data reset. – A. Parort Nov 24 '15 at 1:35
  • just to be sure did you use "dd" on the .zip file or on the .img file ? – lord-ralf-adolf Nov 24 '15 at 1:41
0

Since your device is an AT&T device the proper way to install TWRP is using loki script and binaries follow those steps to re-install TWRP.

  1. Go to this page and download the latest flash-able zip choose => twrp-2.8.6.0-d800.zip
  2. unzip it on your computer and then copy the recovery.img inside the tmp/loki directory and replace the loki.sh with this script.
  3. open a cmd or terminal and type the following commands .
    adb push /path/to/tmp /data/local/tmp
    adb shell
    su
    cd /data/local/tmp
    chmod 777 loki.sh
    chmod 777 loki/loki_flash
    chmod 777 loki/loki_patch
    ./loki.sh
    reboot recovery
  1. the phone will reboot into recovery

** note you can also copy the tmp folder we created using a file explorer on your phone and execute the last seven commands in the terminal emulator on you phone too.

  • 1
    Something must be off with the paths in this sequence of steps. Even if I change to /data/local/tmp/loki in line 4, chmod 777 loki.sh for some reason doesn't give execution permissions to the file and it can't be run. Then even if I run sh loki.sh it doesn't work because it can't resolve any of the paths: they are all referring to the /tmp directory which doesn't exist on the system. Now even if I change all the paths in the script so that all the paths refer to the /data/local/tmp directory, it says that it can't read the aboot.img file. Is this really the correct zip for my phone? – A. Parort Nov 24 '15 at 2:51
  • sorry for the path mismatch my bad I wrote tmp instead of loki ,and yes this is the right zip for you ,and the aboot file is not included in the zip it is generated from your device ,please give it an other try and post the result – lord-ralf-adolf Nov 24 '15 at 2:55
  • 1
    (you would also have to change line 4 to cd /data/local/tmp/tmp I think) This is the error I get: dd: /tmp/loki/aboot.img: No such file or directory loki.sh[8]: /tmp/loki/loki_patch: not found – A. Parort Nov 24 '15 at 3:02
  • @A.Parort did you replace the loki.sh script with the new one I provided ? I edited my answer look at point /2 of my answer – lord-ralf-adolf Nov 24 '15 at 3:05
  • 1
    Of course it will be but you asked for an easier way without re-installing cyanogenmod – lord-ralf-adolf Nov 25 '15 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.