0

The problem: My device (HUAWEI Y536A1) isn't getting detected in Android Studio

The solution: Install the correct usb drivers

The problem that arises to the solution: I am not able to...and here are the details:

I have recently system wiped my computer due to slowness. This brings me back to the tedious task of setting up my computer for Android Studio. I have tried everything to get the USB drivers to work in Android Studio, but for some reason, I can't update my USB driver: enter image description here

Now, here is the annoying screen that always pops up when trying to update my usb driver:

enter image description here

My usb driver is installed:

enter image description here

This is pretty pathetic. I have tried everything. I even tried to go into my computers BIOS and disable Intel xHCI. I also checked, and the virtualization (VT-x) is enabled I remember when I first started Android, I had this same problem, and the solution was to do something in the computer's BIOS, but the problem still persists.

By the way, I have done lots of research on this topic, and this is a code 28, which means it doesn't have the correct drivers:

enter image description here

I have been on this for 3 hours now (3 HOURS!) and would really appreciate any help. How can I get my phone recognized on my Windows 8 laptop? I have done it before, so I know my phone is compatible. I remember doing something with the bios before I had system wiped my computer...

3

First make sure that you have virtualization on in the BIOS.

Next, make sure you have done what I have done in my question.

What I forgot to do was install the android_winusb file in the usb_driver folder. The path should be sdk\extras\google\usb_driver. In my case, C:\Users\Ruchir\AppData\Local\Android\sdk\extras\google\usb_driver

After doing that, go back to device manager and go to the install as path. At the bottom of that should be another option:

Let me pick from a list of devices on my computer

Select your Android phone; it shouldn't have a yellow exclamation point over it any more. After that, select Composite ADB Interface. THAT'S IT.

  • After 48 hours from when you posted your question you can accept your own answer by clicking the check mark beside the answer to change its color to green. – karel Nov 24 '15 at 7:17
  • 1
    @karel I know, and I'll accept it day after tomorrow. Any way, I hope this answer will be helpful for others, and save them 7 hours also – Ruchir Baronia Nov 24 '15 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.