4

Backed up to an sd card using Helium before factory resetting my galaxy s5

Helium could find my backups and gave the option to "restore" before factory reset - after, it's not.

I've tried this method:

  1. Start Helium
  2. pick any "dummy app" to create a backup from
  3. Exit Helium
  4. Check where it placed the backup files, and which files those are (a backup consists of multiple files)
  5. Copy your backup files to that location
  6. Check if for each app there are all the files you've checked above1
  7. Start Helium again, it now should find the backups
  8. Restore whatever you wanted to restore

But it still only sees the recently backed up apps, not the many others I've pasted there. What is different about my previously backed up apps that it is not recognizing? Please help, someone, I'm so confused and I don't have any other backups.

  • 6
    Just a suggestion, in case the Helium issue does not get solved: you can use those backup files (those with .ab extension) with adb to restore the backups. Example usage: adb restore com.carly.app.ab. – Firelord Nov 24 '15 at 6:20
  • That looks like you've already seen my corresponding answer (your method seems to be copied from there), so you've also seen the suggestion @Firelord made. I vaguely remember we had a similar question, and it turned out a file was missing for each app. Unfortunately, I cannot find the post :( Could you compare a "new" backup with an "old" one, to see what kind of files exist for the resp. app? – Izzy Nov 24 '15 at 12:28
  • 1
    You seem to have created a new account, which is why you can't edit this one. Flag this post for moderator attention and let them know which accounts are yours and how to merge them. – ale Nov 24 '15 at 20:18
  • 1
    Please refer help center to merge your accounts. – Manubhargav Nov 25 '15 at 1:51
  • 1
    @Carly AFAIR there were no hidden files involved. Is the number of files from an old backup and from a new backup identical? The backups only consisting of "empty directories" irritates me. As they reside on the SD card usually, it shouldn't be a permission issue either. Could you try ls -la (from a terminal or ADB shell) on those directories? – Izzy Nov 25 '15 at 8:18
1

It's because the files within the com.koushikdutta.backup/files are deleted whenever 1) you uninstall helium backup or 2) phone is factory reset. If those files are missing, helium backup will fail to recognize any of your backups, even if they exist and is easily restorable.

Requiring those files to exist in order to restore backups is honestly quite a retarded system.

0

If you have the premium version of the app (which enables cloud saves) then backup any of your apps to Google Drive, this will create a folder in your Drive which Helium will use for future backups. Then upload your old backup to the Google Drive folder created by Helium. Open Helium again and choose restore from cloud/Google Drive and your old backup will show up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.