3

This is my first time to flash the AOSP build on the device. I just followed Google's instructions to download and build the Android source code. Since I have a Nexus 7 (2013), so I chose the target to "aosp_flo-userdebug" before starting to build. Then I ran "make" to build, and the building was successful.

After that I rebooted the device and went into the bootloader, flashed the device by the command:

$ fastboot -w flashall

The flash succeeded. Then after the device rebooted, it just got stuck on the Google's logo screen and never continued. If I flash it back to the factory image, it can continue booting. So I think maybe there are some mistakes I made during the building or flashing that causes the problem. But I don't know how to find the problem.

I also tried to flash only system.img by:

$ fastboot flash system system.img

But it's still the same result. Hope someone can give me some suggestions. Thanks.

PS: the build version is 5.1

  • Development related questions are off-topic here as this is a site for end-users mostly. Sorry. – Tamoghna Chowdhury Nov 25 '15 at 4:32
  • Oops, posted wrong comment to above commentator. – Firelord Nov 27 '15 at 11:50
2

Thanks to @Tamoghna Chowdhury for linking this to a similar question i had posted. I had similar issues and struggled with it for a while. You need to check some things. Did you flash the device specific binaries ?

In my case there was a version mismatch with the device specific binary and the device. FLO should always have FLO binaries. Otherwise it wont start. Check this post

https://code.google.com/p/aosp4nexus5/wiki/AOSPforNexus5#Automatic_Installatin_of_GApps

I did this long ago, so I don't remember exact step i had take, If you post details of what you have done, maybe i'll remember something.

EDIT :Updating answer based on below comment from OP

Use the second link you mentioned https://developers.google.com/android/nexus/drivers#flolrx22g

Your device is flo. That is the first step. Now, your AOSP build should match with the binaries version. So you cant use 5.1.51 along with binaries of version LMY48G since that is for 5.1.1 . SO checkout AOSP with the same version, i.e 5.1.1 in your case and build again with the LMY48G binaries. I remember i had the same issue but with version 5.0.1 i.e LRX22G. It worked when i checkedout an older source code.

I dont know why this happens, ideally any new version should work. Perhaps another quirks of android. I did not update android later on when the tablet booted correctly. Too big a risk to take :)

  • Thanks for replying. I think I missed the device specific binaries on previous building. So I downloaded the binaries for flo (LMY48G), and ran a building again. But still doesn't work. I noticed there are a bunch of binaries on Google. developers.google.com/android/nexus/blobs-preview and developers.google.com/android/nexus/drivers#flo, I think maybe I used the wrong version of binaries. But how to know which version should I use? The source I'm using is 5.1.51 – popo Nov 25 '15 at 7:17
  • edited my answer. If this doesnt work then I probably cant be of much help – user775093 Nov 25 '15 at 19:44
  • 1
    I solved my problem by getting the binaries from developers.google.com/android/nexus/blobs-preview eventually. Thanks again. – popo Nov 26 '15 at 3:00
  • I think this is now documented in the official site: "AOSP cannot be used from pure source code only and requires additional hardware-related proprietary libraries to run, specifically for hardware graphics acceleration."source.android.com/source/… – Roger Huang May 10 '16 at 1:59
  • This also explains why the preview binaries are needed: "To instead build the AOSP master branch, use the Binaries Preview for Nexus Devices." Anyway, thanks for the sharing : D – Roger Huang May 10 '16 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.