3

This issue just started today and I am at my wit's end because my phone still asks me to sign in to a wifi network which I have been using perfectly well for the past week.

screenshot

These are the details:

  1. I'm using Samsung Note 4
  2. I can use other wifi networks since the issue started, but I can't use the one at home.
  3. I can go online but it disconnects automatically after a few seconds.
  4. Page directs me directly to google and there isn't any sign in prompt there
  5. Nobody else is having the same problem that I have

These are the remedies that I've tried:

  1. Obvious reset of router/phone, I've even restored the router to default and reconfigured it again (still didn't work)
  2. Changed wifi setting from DHCP to Static, sign in prompt disappeared but so did the internet
  3. Cleared cache data
  4. Took out my sim and turned it off for a few minutes (still didn't help)
  5. Downloaded a few apps which were suggested by a few forums I read, nothing happened.

I hope anyone can suggest something that I haven't tried before, thank you.

  • 1
    Go to Settings › WiFi (the place shown in your screenshot), long-tap the network, select "forget", then re-add it. There were several reports where this helped. Let us know then if it worked out for you. Good luck! – Izzy Nov 26 '15 at 18:14
1

When you are asked to sign in to continue, instead of allowing the redirect to open in chrome or any other browser you installed open it with androids built in browser instead.

0

My guess, you are using bsnl broadband with an unlimited plan, for me this happens when the broadband plan reaches it usage limit where the speed declines. So then i use the laptop to open any page and it automatically redirect into the bsnl official site asking to upgrade the plan or to continue with the declined speed n i use to choose the decline option and they ask to restart the modem. later the problem will not happen. But still its a pain to do this every month.

0

You can go tosetting -> WiFi and then forget the WiFi network and then try reconnecting to the network. If you use BSNL Broadband then it may happen because you may have consumed all data you had. It happened with me too. You have to renew your pack or you can use laptop/desktop and go to the redirected page.

0

It's mainly caused because you exceeded the bandwith limit of your ISP.

I faced the same issue with BSNL Broadband. The problem was solved after clicking on an option on the ISP Upgrade page.

protected by Community Sep 4 '17 at 21:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.