0

Recently, I have decided to install a custom ROM on Galaxy Tab 8.9 (Wi-Fi) and messed up everything.

I downloaded some "ICS 4.0.3 or something" .zip file to my root folder. Stupidly didn't install any ROM manager (Play market couldn't download any app in my tablet). Tried to download .apk file, and when failed, I fed up with everything: turned off the tablet, then turned it on with VOLUME UP and POWER buttons pressed. Then in the stock recovery pressed "apply update from sd card" and chose the .zip file...

...the Samsung Galaxy Tab icon was showing up on the screen the whole night. I was thinking that it's being updated and went to sleep. But I was wrong. The next day it was turned off and when I put the charger in, some stupid big charger symbol came up. I can't turn on the device and pressing VOLUME UP and POWER buttons brings me to the recovery menu, where I've tried anything (wipe user data/factory reset, reboot) with no success.

However, when the tablet is in the recovery menu, my PC sees the device through adb when i run "adb devices". I can even push some file to "/data/local/tmp" with "adb push" command. Now I want to know: can I still somehow install some ROM or at least factory reset to my tablet?

"I want to hide under some rock for a couple days until someone helps me"

enter image description here

  • Same way you did it last time: push the .zip file to the SD card, and flash it from recovery. This time, make sure the ROM you're flashing is really intended for the device you're flashing it to – unless your device is named "Samsung or something", the previous one might have been wrong ;) This post might help you finding a match: Where can I find stock or custom ROMs for my Android device? Good luck! – Izzy Nov 26 '15 at 18:18
  • But my tablet doesn't have any SD card slots... – gdrt Nov 26 '15 at 19:36
  • I didn't say "slot" :) It certainly has an internal SD card. Alternatively, you've been able to flash from your "root folder" before, so put it there. – Izzy Nov 26 '15 at 19:39
  • Can I do this with adb, and how? My PC doesn't see the tablet's storage. – gdrt Nov 26 '15 at 20:11
  • Try adb push <update.zip> /sdcard/<update.zip> (replace <update.zip> with the real file name). You can also push it to /data/local/tmp (which you already did before), and then use adb shell to move it to where you want it to be (e.g. via the copy command: cp /path/to/update.zip /new_path/to/update.zip). – Izzy Nov 26 '15 at 20:26
0

Well, no points to leave comment, so here is my (unchecked) advice.

Since You can login via adb, remove zip from sdcard, and reboot tablet into recovery mode, and select restart. I don't think flashing anything or selecting 'wipe' is necessary. Probably the patch didn't even apply. If this will not fix it, then I guess You'll need to adb push working ROM and repeat update from sdcard procedure in recovery mode.

0

Finally I learned what is Odin used for, a tool all samsung noobs need. I've flashed Android ICS 4.0.4 downloaded from this link with Odin(v1.85) and it looks great!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.