1

I have an LG L40 D160 Android phone that repeatedly gives me errors. When it boots, I always get the message "home screen has stopped working". This pops up repeatedly and makes it hard to do anything. Not that there is much to do as the home screen is just black. Internet forums have suggested to delete the app files for the home screen via the settings app, but this didn't bring any change.

This same situation happened less than half a year ago. At that time I sent the phone to LG to get the problem fixed. They simply flashed the phone with a new (or even the same?) firmware.

As this has now occured once again, I don't think this is something that can permanently be fixed simply by flashing the firmware. It seems there is something inherently broken in one of the apps or the firmware itself. I would like to find out which app causes the problem and disable that, if possible.

I am a tech savy person, software developer by trade. However, I have never developed on Android and am therefore not too familiar with the architecture.

I have put the adb logcat output of one boot and shutdown cycle on a filehoster as it is too large for pastebin: http://s000.tinyupload.com/index.php?file_id=01407861783018316845

From looking at the log file, it seems this is the relevant error message:

[ 11-30 19:02:36.686  1410: 1410 F/libc     ]
Fatal signal 11 (SIGSEGV) at 0xd2305848 (code=1), thread 1410 (m.lge.launcher2)

However, I have a hard time deciphering what exactly the problem is. Seems the launcher just dies with a segmentation fault.

I have already tried the following steps but the problem persists:

  • Clearing data for Homescreen app
  • Factory reset of the phone
  • Booting in safe mode
  • Official LG firmware update does not let me re-flash the phone because I already have the latest version
  • Selecting "EasyHome" as my home screen instead just changes the error message to "EasyHome has stopped working"

What can I do to further diagnose the problem? Are there any more temporary files I should be deleting?

  • 1
    Unless you give a log from adb logcat, its kinda difficult to tell from just this much info. But you can probably try backing up things and then factory resetting and see if that helps? Otherwise a little more log would be required to know the issue. usually the first instance of this error you see.... its around those lines you get the reason. – Jaskaranbir Singh Nov 27 '15 at 1:50
  • For the understanding of the log from logcat, consider these resources: How To Logcat || Learn to logcat like a Pro || Doc: debugging with logcat. Later on, update the question with what you understood and also give us the full log (use a paste service for that). – Firelord Nov 27 '15 at 10:17
  • Always use a paste service such as pastebin.com or gist.github.com to show a lengthy code or code-like output. It may be a big turn off to a lot of people if they are asked to download a text file just to take a quick look. – Firelord Dec 1 '15 at 2:11
  • @Firelord I tried, but that file has more than 3MB and pastebin doesn't accept pastes of this size. – Chris Dec 1 '15 at 10:22
1

On 8/15/16 , spoke with a Verizon Tech for my "Homescreen is Not Working"issue. The fix is simple:

Hold Power and Volume Down simultaneously, till the phone powers on

When screen comes back all icons are working.

  • Please mention your device in the answer (by editing)- as it stands you could be talking of some other device which may/ may not help OP or those in future who see your answer – beeshyams Aug 15 '16 at 13:48
  • Tried the previous answer on droi with no change – Chris Albro Jan 24 '17 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.