-1

I downloaded SDK from the official website. I installed it, but when I try to use it this happens:

terminal

What mistake did I make?

I use Ubuntu 14.04.

  • 3
    Does it have executable permissions? What does 'ls -l' gives? – Firelord Nov 27 '15 at 11:40
  • Why don't you just download adb directly ? – SarpSTA Nov 27 '15 at 13:57
1

Did you install additional packages required for adb to work?

According to Google Android's SDK Page

If you are running a 64-bit distribution on your development machine, you need to install additional packages first. For Ubuntu 13.10 (Saucy Salamander) and above, install the libncurses5:i386, libstdc++6:i386, and zlib1g:i386 packages using apt-get:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386

For earlier versions of Ubuntu, install the ia32-libs package using apt-get:

apt-get install ia32-libs

You can check all the dependencies an executable needs using objdump -x ./adb | grep NEEDED.

Make sure all required packages are present in your system. And finally, as @Firelord said, also make sure that the file is executable.

Also have a look at this and this similar questions.

|improve this answer|||||
0

Why don't you just install adb from Ubuntu official repository. Run:

sudo apt-get install android-tools-adb

In terminal for adb and

sudo apt-get install android-tools-fastboot

For fastboot. In this way you can use adb and fastboot in any directory! Make sure your usb debugging is enabled.

|improve this answer|||||
  • Because he has it already. – Tamoghna Chowdhury Nov 28 '15 at 4:41
  • Also, you are right, this will install necessary dependencies, in case they were the problem. – Tamoghna Chowdhury Nov 28 '15 at 4:44
  • "In this way you can use adb and fastboot in any directory!" - that is true but if OP solves the actual problem they can make an alias for the ADB binary in SDK which would work from anywhere in the system too. – Firelord Nov 28 '15 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.