I have purchased some ebooks which I have received in both EPUB and MOBI format.

Can I read these MOBI or EPUB files with the Kindle application ?

I copied the MOBI files into the kindle folder, but they do not show up in my Kindle main screen.


I will answer my own question in the hope in helps others: I just had to reboot my device, and now when I start Kindle the MOBI files which I had copied to the Kindle folder are present in the main screen.

So obviously the Kindle application must be restarted when you add ebooks to its folder (without downloading them via the Kindle store).


Added the Kindle folder:


Force closing and/or clearing the data, does not bring up an EPUB file I just copied to the folder. Will let you know after some more testing.


For those interested: the Calibre software, can convert any e-book between numerous formats (including EPB and MOBI). So, if the EPUB format is not recognized, just convert it to MOBI and use the converted file.

|improve this answer|||||
  • 1
    You might also need to force a re-scan of the SD Card, so that the app recognizes new media in its folder. – Chahk Sep 2 '11 at 14:38
  • Does this also work for the ePubs? Can you also confirm the path in your answer to the specific Kindle folder where you put them, so it gives others a starting reference? – eidylon Sep 2 '11 at 14:39
  • 1
    This worked for me with the .mobi file in the /kindle folder – justinhj Sep 28 '11 at 4:52
  • I was missing everything but force closing and relaunching the app, thanks. – Joshua Aslan Smith Jun 21 '17 at 21:12

For my Nexus 5x which doesn't have an SD card, I needed to create the folder /storage/emulated/0/kindle and place my .mobi files there. Opened up Kindle app, and they are there!

|improve this answer|||||

As of 2018, Kindle did not recognise epub. So I used a web site to convert it to a mobi. But it still did not recognise it. I remembered that apps now needs runtime permissions to access the virtual SD card. So, it the app properties, I gave it the storage permission, and restarted Kindle. Now, it worked.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.