1

My battery on my Alcatel Onetouch Idol S (running Android 4.2.2) is behaving oddly. It will discharge normally, then all of a sudden go from 55% to flat (0%) in seconds. I would put it down to finally rooting it, but I have no cold evidence to prove it. Does anybody know how it can be fixed, or how to figure out why it is happening?

Additional info:

  • I believe the CPU governor should be set to ondemand
  • It was rooted via KingRoot v4.6.0 132, and the KingRoot kernel version is 4.6.0 47
  • The SU version is 3.54
5
  • How old is your battery? You can try the steps in accepted answer here and then my solution, android.stackexchange.com/questions/128091/…
    – beeshyams
    Commented Nov 30, 2015 at 12:38
  • @beeshyams The battery is about a month old. Literally a month. Oh, i will try the second method on that link, but it is the only one i can do at home. There is a irremovable back (though the manufacturers can take it off)
    – Dan Brown
    Commented Dec 1, 2015 at 10:30
  • Curious as to what happened when you tried steps in earlier suggestion
    – beeshyams
    Commented Aug 6, 2016 at 8:14
  • @beeshyams It worked, kinda. My phone did not turn on. Charged it to find it was drained, and it had a normal discharge when booted. I done that about a day ago.
    – Dan Brown
    Commented Aug 6, 2016 at 9:56
  • Good. Hope it gets to be normal
    – beeshyams
    Commented Aug 6, 2016 at 10:45

0

You must log in to answer this question.

Browse other questions tagged .