1

I'm going to stay on topic and make the long story short. My phone (International Galaxy S3) has its USB port broken and can't replace it because I messed it up when I was on it. Since then I use an external battery charger. Now I need to root my phone and flash a custom recovery and since the easy way (Odin) is with USB I have to try something else. I have already tried rooting with different apps (Framaroot, towelroot, KingRoot) with no success.

I have been reading on internet to figure out a way to root it or flash a custom recovery but everything comes into a dead end. One of the possible solution I have found is rooting phone via Android Stock Recovery (the 3e one), but this would require a signed update.zip. Is this possible or it could hard-brick my phone? If it is possible, how do I make it?

The zip file needs to be signed and have a certain folder organization (META-INF and system). I could sign it with an app I discover in xda forums called Sign'em (can this work out?). But I have no idea about folder organization of the update.zip file. I downloaded a file called "Update-SuperSU" from chainfire's website which comes with META-INF folder but instead of system there are 3 extra folders: common, arm and x86. Is it the same?

If there is another way to root the phone or flash a custom recovery to do so, please tell me. Any help will be appreciated

  • Have you tried this? It is a CWM_SuperSU.zip file contains both custom recovery and su binaries – Manubhargav Dec 1 '15 at 5:26
  • Also which Android version are you on? This guide here claims to root the phone with latest firmware. – Manubhargav Dec 1 '15 at 5:32
  • Hi, thanks for reply. That first guide says I need CWM recovery installed, which I don't (Stock 3e Recovery). Also the zip is a link to chainfire's zip which includes Odin and the .tar. I'm on 4.3 Official (latest OTA update available). And I have already mentioned I tried KingRoot method of that 2nd guide and didn't work for me – Jalt Dec 1 '15 at 5:35
  • If by broken you mean, the usb port was knocked loose from fhe board, then you'll need to get it soldered back in place if possible. Without some kind of existing root you cannot dump or write an *.img [recovery,boot,etc.] – moonbutt74 Dec 1 '15 at 19:09
  • @moonbutt74 When I was replacing the usb port I messed it up with solderer, and I think that place of the PCB is non-fuctional now. So if I sign an update.zip with the rooting requiered files and then flash with Stock 3e Recovery, that won't work? – Jalt Dec 1 '15 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.