2

I have a Samsung Note 4, with android 5.1.1. And I have an on-line music player installed on it. The player can download music from the Internet, and the files are stored in the external SD card. But it has a deep path, such as extSDCard/Android/data/com.xxx.xxx/music/... For some reason, I want to use the stock music player to play these files. But it just can't find them.

I tried copy some files from the deep path to a folder called "music" in the root of my SD card, then the stock player can find it, but I can't change the download path of my on-line music player and I don't want to do a copy or move every time when I download music.

So, any good suggestions to make the stock music player find the files?

  • 1
    Because exSDCard/android/data/ contains .nomedia file. Android's mediaserver respects that and doesn't scan the directory containing that file. Hence, your music player or a picture viewer (both depends upon mediaserver) won't get anything from that directory to show you. Should you remove that file, unnecessary media from other apps' directory will also get scanned and show up. – Firelord Dec 2 '15 at 4:08
  • But even after deleting the .nomedia file under Android/data folder, it still can't find the files. – diverger Dec 2 '15 at 5:23
  • Also, even if not for the .nomedia file, the extSDcard/Android/data directory is considered a system directory, and will not be evaluated by stock apps except for the file manager and those apps which concern themselves with it directly. Have you considered using an alternative music player app such as MX Player or JetAudio? – Tamoghna Chowdhury Dec 2 '15 at 7:19
  • Umm, in some situations, the stock music player is the only choice, such as under voice control or using the remote control buttons on the headphones, it can only start the stock music player to play music. ( If there is method to make other players to start, please tell me:). ) – diverger Dec 2 '15 at 7:41
  • BTW, the JetAudio has the same problem with the stock music player!!! – diverger Dec 2 '15 at 7:42
0

I think (!) the answer lies in the length of the path to the file(s). I'm experiencing similar issues, and I solved it for one file by simply shortening the filename.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.