2

Device: Oneplus One

Android version: 6.0

Cyanogenmod 13.0

Today, I saw there was an update for 20151203 OTA and decided to download it and flash it via TWRP like I usually do. Before that, I was running on 5.1.1 (I think) and I didn't realize that it was updating me to Android 6.0 until my phone rebooted. Upon flash and reboot, I have the following errors

  1. Google Play Services has stopped working: The popup is constant and annoying, sometimes stacking up and by the time I close one stack, another one appears! Makes the phone impossible to use. I read up on a few solutions, where one said - set your location services to "Device Only" and the other was go to settings → apps → reset app preferences. Tried both, didn't help much, still have the annoying popup.

Also, in my notification tray, there is a message saying "Google Play Services won't run unless you update Google Play Services". Everytime I click the notification, it opens a few activity which is just blank, I can't do anything. Google Play is present in my app drawer but on clicking it, I get the same blank screen.

  1. Ever since I flashed, I'm unable to browse my files via my computer. I connect it via the USB cable and while my system is able to identify my device and even asks me if I'd like to browse it's files, when I click "Okay", I get a blank page as if my device has nothing (not even an internal storage option like before). However, my files are intact on my device for I'm able to use file manager and browse it on the device itself.

The problem I kind of solved partially by toggling the USB Configuration type (which was on MTP by default) to something else, then toggling it back. Not quite sure why it happened, but that's how I fixed it for the time being. Although, the second bug isn't completely gone. On rebooting the phone and the connecting it to my system, I'm presented with the same problem. However, on toggling that config type again, it appears, but one can't be expected to do this everytime he wants to connect the phone to his system right?

Any help will be greatly appreciated!

EDIT: Shout out to Tamoghna Chowdhury for the quick help. Finally resorted to wiping, and clean flashing CM13 along with GAPPs for MM. Everything works fine now. Thanks for all your help!

  • 1
    Well, there isn't Android 5.1.2, I changed it to 5.1.1 (it could be 5.0.2 BTW). Did you have CM 12.1 or 12.0 earlier? Also, the 2nd problem is general to all 6.0 devices – Tamoghna Chowdhury Dec 3 '15 at 7:24
  • 1
    No, you're right, it would've been 5.1.1, thank you very much for that. Also, to answer your question, I had CM 12.1 before that. Also, I just tried downloading the Google Play Services apk for 6.0 from online and tried to install it manually. It just says "App was not installed" at the end of it. Uninstall / Force stop for my currently installed Google Play Services is greyed out too. Thanks for your help! – Izy- Dec 3 '15 at 7:26
  • 1
    Could you try getting a signed GAPPs pack for MM and flash that? Also, is a clean flash out of consideration? – Tamoghna Chowdhury Dec 3 '15 at 7:27
  • 1
    And regarding the second problem, I can live with it until a fix is rolled out. But any ideas on the first problem? That's a real pain! All google related apps that I have aren't working either since they use the services too. Edit: I have downloaded GAPPs for MM. Just about to flash it. And clean flash is possible, but I'm trying to keep that as a last resort. – Izy- Dec 3 '15 at 7:27
  • 1
    I'm about 60% sure the GApps problem is due to the OTA update (a dirty flash in our terms). If you can do so, completely clean reflash a CM 13 zip (full, not an OTA update from 12.1), and flash a compatible ARMv7 CM13 GApps pack over it. – Tamoghna Chowdhury Dec 3 '15 at 7:29
2

I'll address your 2nd problem 1st, as that is a simpler thing to describe.

I suffer from the same issue on a stock HTC Nexus 9 (6.0, MRA58K). Whenever I connect it to my PC, it defaults the USB connection mode to "Charge Only", and I have to toggle it back to "MTP" from the persistent notification in the statusbar.

AFAIK this is a general problem with Marshmallow, and one of my friends with a OnePlus One with CM13 also experiences this issue. I'm sorry, but we can only hope some enterprising developer corrects this oversight/bug/feature soon in AOSP.

Edit:

From @Firelord's comment, it appears that the Marshmallow default of "USB Charging" is a deliberate feature in Android 6.0. This is highly inconvenient for some users. See the Android 6.0 official change log here. This link is courtesy of @Firelord's answer here.

Now, the 1st problem.

This error of "Google Play Services has stopped" is common after "dirty-flashed" updates. Since the /data partition remains untouched by an OTA update or a dirty flash, the updated versions of the system apps it stores for Lollipop will interfere with the inbuilt, higher versions for Marshmallow which are in the newly-flashed '/system` partition.

Since you use TWRP recovery, I'll recommend wiping /data and clean flashing a full CM13 zip for the Oneplus One with a compatible (ARMv7 Android 6.0 CM13) GApps package zip. Use TWRP's default wipe of /data without /data/media to keep the data on your (emulated) internal SD.

In the future, consider only OTA updating between minor version upgrades, e.g. from 5.0 to 5.1 or 5.1 to 5.1.1, not 5.1.1 to 6.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.