I recently flashed CyanogenMod Nightly 12.1 on my YU Yuphoria, followed by ARM64 Micro Open GApps package. When I booted after successfully flashing, I had to do the system setup which is to be done anytime when the data is reset. I almost completed it but when I reached the step where I need to sign into my Google Account, it shows

Checking info..

And then in 1-2 seconds I get an error screen saying

Unfortunately, Google Play Services has stopped.

What could be the reason behind it? I'm not able to complete the system setup and use my custom ROM.

  • 1
    Its incompatible GApps problem. Try some other. The details you gave are not sufficient to reach a relevant decision.? Dec 5 '15 at 5:18
  • I was confused before flashing.. My YU Yuphoria is a 64-bit device but I wasn't sure whether the CM nightly is 32-bit based or 64-bit based.. So I asked on the official YU forums, and they asked me to download the ARM64 Micro Package..
    – Tanmay Vij
    Dec 5 '15 at 5:21
  • What happens if you tell it to skip, then finish the start up process it, Then go into the settings and add the account from there?
    – jer3my
    Dec 5 '15 at 11:36
  • @jer3my I thought of doing it but then I wouldn't have been able to restore the data (settings, WiFi passwords etc) saved in my Google account..
    – Tanmay Vij
    Dec 5 '15 at 14:28

Problem solved..

The problem persisted only till the time I had been using Open GApps.. Then I checked out for GApps on the official CyanogenMod website and got an idea to try CGApps instead of Open GApps.. So I downloaded the ARM64 package of CGApps and flashed it.. Thankfully it worked for me.. So if someone's facing problems with Open GApps, CGApps is definitely worth a try..

  • Mark your own response as "answer"
    – code_flow
    Dec 6 '15 at 8:43
  • I'm sorry I couldn't get you.. Do you mean I shall mark my answer as my accepted answer to the question?
    – Tanmay Vij
    Dec 6 '15 at 11:42
  • That is correct.
    – code_flow
    Dec 6 '15 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.