1

Like many of you I eagerly awaited the release of the nexus 6p.. unfortunately it has been crashing a lot lately (a problem many seem to have). The first thing I tried was running a factory reset, which solved the problem temporarily.. but a couple of weeks later the problem returned (i noticed it returned after a certain mass update i made to several apps).. so i'm quite certain it's a software problem rather than a hardware defect.

I'm not an android developer.. but i did a bit research on logcat etc.. and I made this command logcat -L *:E the output is pasted in this github gist. (here is the verbose version)

Any advice? I've also installed aLogcat but i'm not quite sure how to use that.. i've seen some posts talking about instructing it to dump the output on an SDCard.. but i don't see that it has a command line interface..

Update 1

i got to install android 6.0.1.. everything worked perfect for several days.. however as soon as i started taking pictures.. the old crashes came back.. which reminded me that the exact same thing happened when i first got the phone.. so i narrowed down the problem to the camera app.

Update 2

I've asked the same question on the google nexus forum. Some helpful tips bit still no cigar.. i'll post the answer here if i actually solve it.

0

after going through the logs we found this part:

fs_mgr: Running /system/bin/e2fsck on /dev/block/platform/soc.0/f9824900.sdhci/by-name/userdata
<14>[    6.585352] e2fsck: e2fsck 1.42.9 (28-Dec-2013)
<14>[    6.585352] 
<14>[    6.585390] e2fsck: ext2fs_open2: Bad magic number in super-block
<14>[    6.585390] 
<14>[    6.585402] e2fsck: /system/bin/e2fsck: Superblock invalid, trying backup blocks...
<14>[    6.585402] 
<14>[    6.585414] e2fsck: /system/bin/e2fsck: Bad magic number in super-block while trying to open /dev/block/platform/soc.0/f9824900.sdhci/by-name/userdata
<14>[    6.585414] 
<14>[    6.585424] e2fsck: 
<14>[    6.585424] 
<14>[    6.585434] e2fsck: The superblock could not be read or does not describe a correct ext2
<14>[    6.585434] 
<14>[    6.585445] e2fsck: filesystem.  If the device is valid and it really contains an ext2
<14>[    6.585445] 
<14>[    6.585455] e2fsck: filesystem (and not swap or ufs or something else), then the superblock
<14>[    6.585455] 
<14>[    6.585466] e2fsck: is corrupt, and you might try running e2fsck with an alternate superblock:
<14>[    6.585466] 
<14>[    6.585476] e2fsck:     e2fsck -b 8193 <device>
<14>[    6.585476] 
<14>[    6.585486] e2fsck: 
<14>[    6.585486] 
<14>[    6.585501] e2fsck: e2fsck terminated by exit(8)
<14>[    6.585501] 

which shows that the file system is corrupt.. i guess that's it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.